Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Ubuntu 10.10 installed on my laptop and connected via wireless lan to my home network. Now I want to play around with my old wifi equipment which I need to configure first. But every time I plug the ethernet cable in and the link on eth0 becomes ready Ubuntu disconnects my WLAN connection. Which is extremely annoying as I can't surf as along as I'm connected via (cable) ethernet. Or generally speaking: As long as I'm connected with a network from the "wired" tab.

I already checked "Available to all users" for my WLAN and Wired network so that they are available when I log in. But this doesn't affect the problem mentioned above.

Do I need to get rid of the NetworkManager to be able to stay connected to my WLAN and Wired network at the same time? (They don't share the same network address pool. WLAN is static IP, Wired is DHCP with differenct IP network.)

share|improve this question

1 Answer 1

You'll want to go in the connection's configuration settings, under the IPv4 Settings tab, click the Routes button, and check the checkbox marked "Use this connection only for the resouces on its network".

What this does is tell NetworkManager to not use that connection as a default route. However, you'll need to edit it again to remove that option if you want to use wired as a connection for the internet (or create a separate connection just for changing old wifi settings).

where to change the settings

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.