Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just got a new laptop, and installed narwal on it. Things like youtube videso play fine, however "system graphics" (for lack of a better term) are extremely jerky, for example closing a tab will take several seconds, or even typing in this text box gets several seconds behind where I am typing. My system hardware is pretty beefy, so it's not a hardware issue: Intel Quad core 2GHz, 8GB of RAM, and a radeon 6570M with 1GB (running the proprietary driver).

share|improve this question
    
Not an answer to your question, but usually things like this happens in a freshly released distribution. Since you just got the laptop, try installing 10.04 LTS instead or wait until 11.04 becomes stable. (Patches are submitted overtime to solve problems like this) –  Dananjaya Apr 26 '11 at 20:32
    
I've run Ubuntu alphas for the last few releases, so I'm used to the gradual stabilization. I'm trying to establish if this is known bug (that I could follow), something I should report, or a case of "twiddle these settings". –  Alex Gaynor Apr 26 '11 at 20:37
    
A different ATI VGA but symptoms are somewhat similar askubuntu.com/questions/36182/… –  Dananjaya Apr 26 '11 at 20:40
    
What about the opensource driver? My nvidia runs better with nouveau. –  wojox Apr 26 '11 at 20:43
    
You might consider "upgrading" to the latest build of Natty Narwhale later today when it gets released. What theme are you using? –  alexy13 Apr 28 '11 at 10:24

3 Answers 3

up vote 1 down vote accepted

try the latest amd-ati-catalyst-114

share|improve this answer
    
This seems to have helped, though not solved the problem completely. The problem also appears to be minimized by using Chromium in place of Firefox. –  Alex Gaynor Apr 28 '11 at 14:30

Disable Detect Refresh Rate, and Sync To Vblank

  • Install CompizConfig SettingsManager by running the following command in a terminal:

    sudo apt-get install compizconfig-settings-manager

  • Launch it by searching from the dash in Unity, or find it under Preferences > CompizConfig Settings Manager in Ubuntu Classic.
  • Click on the Composite tab, and un-check Detect refresh rate. enter image description here enter image description here
  • Click on the OpenGL tab, and un-check Sync to Vblank. enter image description here enter image description here
share|improve this answer

In compizconfig settings manager, go into openGL (under general options) and uncheck the option that says "Sync To VBlank". This is what worked for me, and a friend of mine.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.