Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I run an Ubuntu Server 12.04.3 LTS. Today, I wanted to update it, but I did not managed it (yes...), however upgrading worked well. I don't want you to solve my problem but it would be greatful if you could give me some hints. I googled hours, I fould a lot of this kind of errors, but not exactly this.

Here is the output of apt-get update:

Hit precise Release.gpg
Hit precise Release
Hit precise/main amd64 Packages
Hit precise/restricted amd64 Packages
Hit precise/universe amd64 Packages
Hit precise/multiverse amd64 Packages
Hit precise/main i386 Packages
Hit precise/restricted i386 Packages
Hit precise/universe i386 Packages
Hit precise/multiverse i386 Packages
Ign precise/main TranslationIndex
Ign precise/multiverse TranslationIndex
Ign precise/restricted TranslationIndex
Ign precise/universe TranslationIndex
Ign precise/main Translation-en_GB
Ign precise/main Translation-en
Ign precise/main Translation-en_GB.UTF-8
Hit precise Release.gpg
Ign precise/multiverse Translation-en_GB
Ign precise/multiverse Translation-en
Ign precise/multiverse Translation-en_GB.UTF-8
Ign precise/restricted Translation-en_GB
Ign precise/restricted Translation-en
Ign precise/restricted Translation-en_GB.UTF-8
Ign precise/universe Translation-en_GB
Ign precise/universe Translation-en
Ign precise/universe Translation-en_GB.UTF-8
Hit precise Release.gpg
Hit precise Release
Hit precise Release
Hit precise/main Sources
Hit precise/restricted Sources
Hit precise/main i386 Packages
Hit precise/restricted i386 Packages
Hit precise/multiverse i386 Packages
Hit precise/main TranslationIndex
Hit precise/multiverse TranslationIndex
Hit precise/restricted TranslationIndex
Hit precise/main Translation-en_GB
Hit precise/main Translation-en
Hit precise/multiverse Translation-en_GB
Hit precise/multiverse Translation-en
Hit precise/restricted Translation-en_GB
Hit precise/restricted Translation-en
Hit precise-security Release.gpg
Hit precise-updates Release.gpg
Hit precise-security Release
Hit precise-updates Release
Hit precise-security/main amd64 Packages
Hit precise-security/restricted amd64 Packages
Hit precise-security/universe amd64 Packages
Hit precise-security/multiverse amd64 Packages
:W: Failed to fetch  Unable to find expected entry 'main/binary-amd64/Packages' in Release file (Wrong sources.list entry or malformed file)

E: Some index files failed to download. They have been ignored, or old ones used instead.
Hit precise-security/main i386 Packages
Hit precise-security/restricted i386 Packages
Hit precise-security/universe i386 Packages
Hit precise-security/multiverse i386 Packages
Hit precise-security/main TranslationIndex
Hit precise-security/multiverse TranslationIndex
Hit precise-security/restricted TranslationIndex
Hit precise-security/universe TranslationIndex
Hit precise-updates/main amd64 Packages
Hit precise-updates/restricted amd64 Packages
Hit precise-updates/universe amd64 Packages
Hit precise-updates/multiverse amd64 Packages
Hit precise-updates/main i386 Packages
Hit precise-updates/restricted i386 Packages
Hit precise-updates/universe i386 Packages
Hit precise-updates/multiverse i386 Packages
Hit precise-updates/main TranslationIndex
Hit precise-updates/multiverse TranslationIndex
Hit precise-updates/restricted TranslationIndex
Hit precise-updates/universe TranslationIndex
Hit precise-security/main Translation-en
Hit precise-security/multiverse Translation-en
Hit precise-security/restricted Translation-en
Hit precise-security/universe Translation-en
Hit precise-updates/main Translation-en_GB
Hit precise-updates/main Translation-en
Hit precise-updates/multiverse Translation-en_GB
Hit precise-updates/multiverse Translation-en
Hit precise-updates/restricted Translation-en_GB
Hit precise-updates/restricted Translation-en
Hit precise-updates/universe Translation-en_GB
Hit precise-updates/universe Translation-en

And here is my /etc/apt/sources.list:

###### Ubuntu Main Repos
deb precise main restricted universe multiverse
# deb precise main restricted universe multiverse
deb precise main restricted universe multiverse

###### Ubuntu Update Repos
deb precise-security main restricted universe multiverse
deb precise-updates main restricted universe multiverse
deb precise main restricted multiverse
deb-src precise main restricted multiverse

Thanks for your help!

share|improve this question

1 Answer 1

up vote 1 down vote accepted

The repositories, has no main, nor restricted, nor universe, neither multiverse. Is a partner only repository:

enter image description here

enter image description here

You should modify this line:

deb precise main restricted universe multiverse

so it reads like this:

deb precise partner
share|improve this answer
Thank you so much, it worked! – user171447 Nov 6 '13 at 14:20

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.