Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm running Kubuntu 13.10, my computer's graphics card is Nvidia GT 520. I tried to fix that Plymouth's problem with proprietary graphics driver using an old script I found on the internet (it was coded for Natty, now that I think about it I shouldn't have done it). I ran that script and rebooted my computer.

First incorrect behaviour I noticed was that Plymouth only displayed its text splash only on 1/4th of the screen, though when I pressed Esc key the logs were displaying correctly.

Main problem appeared when I logged in. All my desktop's windows lack menu bar, can't be closed with Alt-F4, and they don't appear on the taskbar.

I tried fixing it by reinstalling GRUB a few times, purging /etc/grub.d and /boot/grub, but only the text splash issue was fixed. How can I fix that?

This is the script I used.

share|improve this question
What script did you run ? – bodhi.zazen Nov 5 '13 at 21:38
@bodhi.zazen… – Michcioperz Nov 5 '13 at 21:45
That is a horrible script, it over writes system files without making back ups and there is no function to un do these changes. In addition, I suspect there are some sections that do not do what the author intends as using single quotes will insert the variable name (for the resolution) rather then the contents of the variable. – bodhi.zazen Nov 5 '13 at 21:59

I am not sure if this will fix it, but ...

sudo apt-get purge v86d

As root, edit /etc/initramfs-tools/modules and remove the line "uvesafb mode_option=$resolution mtrr=3 scroll=ywrap"

As root, edit /etc/initramfs-tools/conf.d/splash and remove the line "echo FRAMEBUFFER=y"

Then run

sudo update-initramfs -u
sudo update-grub2

That might fix the problem, assuming you purged and re-installed grub2 (looks if all the other files edited were grub files).

share|improve this answer
I already tried reverting what script did to the system, so yeah, I purged and re-installed grub and I edited those files you mention. – Michcioperz Nov 5 '13 at 22:06
@Michcioperz and? – Braiam Nov 5 '13 at 22:06
Did you rebuild your initramfs ? – bodhi.zazen Nov 5 '13 at 22:07
Yes, I did it all. I tried again now, and it still doesn't help. I however noticed another detail that may be helpful - virtual screens are unavailable, and visual effects don't work, could this script affect Compiz somehow? – Michcioperz Nov 5 '13 at 22:10
Try creating a new user. If KDE works when you log in as a new user, then my guess would be your config files (.kde) are corrupt. If it does not work, then I am not seeing any additional problem and I do not see how that script would affect compiz. Are you even running compiz with KDE ??? – bodhi.zazen Nov 5 '13 at 22:14

You should read carefully what you are doing, that article is for Natty or 11.04 which is 2.5 releases from the one you are using.

Let's dissect what the script did:

  1. It installed v86d and hwinfo packages. Both can be removed:

    sudo apt-get --purge autoremove v86d hwinfo
  2. There are several lines added to several files around all the system.

    sudo sed -e 's/FRAMEBUFFER\=y/d' /etc\/initramfs-tools/conf.d/splash
    sudo sed -e 's/uvesafb/d
  3. Then it modifies /etc/default/grub and /etc/grub.d/10_linux, you can recover the original files by reinstallation:

    sudo apt-get --purge autoremove grub-pc
    sudo apt-get install grub-pc


  4. Run sudo update-grub2 and sudo update-initramfs -u

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.