Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Today I've installed a new Asus RT-N10E router, as I switched from DSL to a cable ISP. Honestly, I can't recall which security settings I used on the previous one. Thing is, that's I want it to be WPA2 Personal (with AES, that an only option in my router); WPA-TKIP works at about 50 Mb/s but I want the better 60 Mb/s throughput and security of WPA2-AES. Windows XP and both phones connect to the WLAN correctly. My Ubuntu 13.10 with Broadcom STA driver (BCM4313) also connects to the network, at least the indicator says so, but I can't access the internet w/ WPA2-AES.

I put the results of the wireless-info script on pastebin.com because of the question length limitation. So, here it is: http://pastebin.com/2xJ6MYit

share|improve this question
    
I've tried WPA and indeed, it's working. The problem is that now I have only option to choose TKIP. And it's not WPA2. :) Thanks for the advice (so I can use the internet), but I'm waiting for the real solution. –  Luke Nov 5 '13 at 19:07
    
I've also noticed that in WPA-mode my bandwidth is limited to about 50 Mb/s (limitation comes from the router itself). –  Luke Nov 5 '13 at 19:53
    
As I researched it a bit, fault is on the Linux's side. I have Asus RT-N10E. –  Luke Nov 5 '13 at 20:25
    
It should be 60 Mb/s. BTW I can use my router not only to browse web, but also for example to send files through LAN. ;) –  Luke Nov 5 '13 at 22:26
    
Visit ubuntuforums.org/… and then reply there with the result of the script mentioned in the link. ubuntuforums.org/showthread.php?t=2131289, ubuntuforums.org/showthread.php?t=2175219 and ubuntuforums.org/showthread.php?t=2174901&p=12791184 have useful info. –  K7AAY Nov 5 '13 at 23:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.