Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Maverick at the moment and the default music player is Rhythmbox. It interfaces with the panel through the sound menu, so you can see it playing like this:

Screenshot of Rhythmbox playing in the Sound Menu

I know that, in Natty, Banshee is due to be the default music player, so I was trying it out the other day to get to grips with it. How can I change which music player interfaces with the panel like this (from Rhythmbox to Banshee and then back again)? Because, at the moment, when I run Banshee, I just get this:

Screenshot of the Sound Menu with Rhythmbox but not Banshee

...and no Banshee integration.

share|improve this question

5 Answers 5

up vote 3 down vote accepted

Really has nothing to do with 'Default', you can have several players in the sound menu,they'd be listed top down in order of install/activating, in other words the order listed in com.canonical.indicators.sound - interested-media-players which can be adjusted as desired.

Atm there are at least 3 specifically enabled - banshee, rhythmbox, clementine, additionally vlc-1.2+ has MPRIS2 support & works to some extent.

From my perspective the 'quality' of sound menu support is best in banshee closely followed by clementine & rhythmbox. Banshee & clementine seem to lack album art in the menu. (I not sure if guayadeque has or will have support

Vlc works ok, has album art but as it wasn't specifically coded for the sound menu it can't be minimised to it, only opened & controlled from it.

There is some interest possibly for audacious but nothing yet.

Unless you or someone else is up to the task of adding MPRIS2 & then enabling as intended for the sound menu then yes, you are "dependent on the developers of the music players.." not only for MPRIS2 but also proper integration into the menu.

screen example - enter image description here

share|improve this answer
    
Doug, how do you add VLC to the Unity Panel like that please? –  user47512 Feb 22 '12 at 9:03
    
Matt - if you have vlc-2.0 as a minimum & it's not showing in the sound menu then try this - Open vlc > Tools > Preferences. Change something on the main Interface screen like "Allow only one instance" & or pick a new option from the 'Privacy" drop down like "as soon as track starts playing. Save, close & reopen vlc. Otherwise you could also try adding to the 'interested players' in dconf-editor > com.canonical.indicator.sound –  doug Feb 24 '12 at 0:31

I uninstalled Banshee and then installed Rhythmbox. Rhythmbox showed in Dash and in the sound indicator without any additional intervention from me that I recall. If you wish to keep multiple players around I suggest you open System Settings and select System Info. There you can adjust Default Applications. That's where I changed Firefox to Chrome after installing it and Chrome shows up in Dash as the default browser even though within Chrome I never designated it as my default browser.

share|improve this answer

Have a look through dconf-editor at apps.indicators.sound. There are a couple of options there that might be relevant. I've switched my menu from Banshee to Rhythmbox. I did so by blacklisting banshee and adding rhythmbox to the list of interested media players.

I hope that that will help you.

share|improve this answer

System Preference -> Preferred Applications -> Media Player. You can choose your preferred application there.

share|improve this answer
    
Still works nicely in 13.10, although it is opened differently. From the Dash, open Details, select Default Applications, and change Audio to your preferred app. –  eksortso Dec 8 '13 at 7:10

It doesn't matter which music player is default. When you install banshee or rhythmbox it should add itself to the sound menu. However you need to logout and then login again to see the changes in the sound menu.

However just to make sure, click Edit -> Preferences -> Extensions and see if the sound menu extension is enabled. (See the screenshot below for more details)

enter image description here

share|improve this answer
    
Great, thanks, it was the sound menu integration extension that I was unchecked. Works great now. –  Slipstream Apr 26 '11 at 19:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.