Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just upgraded to Ubuntu 11.04 Beta 2 from Ubuntu 10.10 on my netbook (a Dell Mini 1012). The problem is I have a HP Laserjet 1018 printer which I had it installed in Ubuntu 10.10 without any problems.

But after I've upgraded to 11.04, every time I plug it in it asks for downloading the proprietary plugin and installs it then when I remove the cable and plug it in again it downloads the plugin again.

I never had this problem in 10.10. Does anyone know how to solve this problem?

share|improve this question

the answer in this posting solved this problem for me.

In short:

sudo getweb 1018
sudo hplj1018
share|improve this answer

It is bug in hplip of ubuntu 14.04:

The workaround is to downgrade hplip to the version from ubuntu 13.10:

  1. Remove hplip of 14.04 (for some reason apt-get won't do that automatically)

    apt-get remove hplip
  2. Add repo strings for 13.10

    cat > /etc/apt/sources.list.d/saucy.list <<EOF
    deb saucy main restricted
    deb saucy universe
    deb saucy multiverse
  3. Update apt's db

    apt-get update
  4. install hplip of 13.10

    apt-get install hplip=3.13.9-1 libhpmud0=3.13.9-1 libsane-hpaio=3.13.9-1 \
        hplip-data=3.13.9-1 printer-driver-hpcups=3.13.9-1
share|improve this answer

Instead of installing the proprietary plugin, try HPLIP. (Since 11.04 is beta, this may be a bug as well)

share|improve this answer

I had the same problem

Deleted the printer installation, turned it off and unplugged the USB connector

Opened the Synaptic Package Manager and removed HPLIP, HPLIP DATA, and HPLIP CUPS

Shut the computer down, then restarted and installed the removed packages. Connected the USB cable and turned the printer on. The system installed the printer automatically without any plugin downloads and printed normally. Hope this helps

share|improve this answer

I also had a problem with my HP 1018 printer upon upgrading to Ubuntu 11.04 Natty Narwhal. I tried gymador's suggestion but it didn't work. This is what worked for me

  1. Make sure you have "hplip" installed in Synaptic
  2. Go to the terminal and type sudo hp-setup -i and follow the prompts to install the driver/plugin

It should work now

EDIT: Actually, the process I outlined above only worked for one print of a document and failed again afterwards. I then tried this to make it work: 1. go to Synaptic and install "hplip-gui" 2. go to the dash and type in "hplip" and launch "hplip toolbox" 3. Click on the HP laserjet 1018 on the left 4. make sure you're on the actions tab 5. click download firmware 6. try printing something

It worked again for me, but I don't know if it'll keep working afterwards though.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.