Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

It seems Guake terminal is not aware of the Unity sidebar being hidden. Even when the sidebar is hidden, it still shows with a left offset that is based on the width of the sidebar.

Additionally, the width of the terminal is not decreased by the width of the left offset, which causes the terminal to appear on my second monitor as well.

Is there a way to fix this?

Guake terminal showing up incorrectly in Unity

share|improve this question
add comment

7 Answers 7

up vote 16 down vote accepted

As a work-around, you can adjust the Guake terminal width to less then 100% of the screen width.

  1. Make a backup of /usr/lib/guake/guake.py for Ubuntu 12.04 and for Ubuntu 12.10 and newer, backup /usr/bin/guake file.

  2. Open a terminal and run the following command:

    For Ubuntu 12.04:

    sudo -i
    gedit /usr/lib/guake/guake.py
    exit
    

    For Ubuntu 12.10 (or newer) Guake versions, use the following command instead:

    sudo -i
    gedit /usr/bin/guake
    exit
    
  3. Then scroll down to somewhere around line 780-820 which says width = 100 - this is how it looks like:

    screen = self.window.get_screen()
    height = self.client.get_int(KEY('/general/window_height'))
    width = 100
    halignment = self.client.get_int(KEY('/general/window_halignment'))
    

    And modify the width value (percentage) to whatever you want. Save the file, restart Guake and that's it.


Reference: WepUp8 Article

share|improve this answer
    
Thanks! Note in Ubuntu 12.10 it is: gksu gedit /usr/bin/guake –  tobigue Jan 30 '13 at 17:21
    
Pardon me but how do I restart guake? exiting and reopening guake with <kbd>F12</kbd> did not work (the setting did not change). Is there an option other than killing the guake process? –  aditya menon Feb 17 at 15:25
    
Right click it and select Quit. –  Alin Andrei Apr 30 at 13:28
add comment

I had another problem. The first few lines of guake were hidden by the Unity top panel. This can be solved changing the variable "window_rect.y" in line 835 (Natty) from 0 to 30, as shown below.

window_rect.y = 30

share|improve this answer
    
Thanks for this solution. It helped me after switching from Ubuntu with Unity to XUbuntu with XFCE desktop. –  therealmarv Sep 26 '12 at 16:47
    
You helped me a lot! I just upgraded to Raring and Guake was showing lower than it should. Changing that setting solved my problem! –  bakytn Apr 26 '13 at 10:41
add comment

In 12.04, default configuration with side bar always shown, the problem with guake is that the right side of the terminal output is hidden. It seems that is not aware of the real visible size available. Using Alin Andrei suggestion with

width = 95

I was able to fix it.

share|improve this answer
add comment

I have a better workaround, or rather, a fix.

Open /usr/lib/guake/guake.py and scroll to line 786 containing:

self.window.move(window_rect.x, window_rect.y)

Move it under this line, no 788:

self.window.show_all()

All works as expected after a restart of Guake - at least for me up to now.

share|improve this answer
add comment

Yes, go and fix Guake's code! :)

To be more serious, we are working on the positioning and sizing issues.

share|improve this answer
2  
Someone should make a Guake lens so it's all nice and integrated! –  Jorge Castro Apr 26 '11 at 14:44
    
@Jorge: hmmm so it's possible to embed applications into lenses? –  Alin Andrei Apr 26 '11 at 20:03
    
@Alin We could probably embed a VTE widget into a lens. If anyone is interested in doing this work have them get ahold of me (link in my profile) and I'll point them towards the right Unity developer. –  Jorge Castro Apr 26 '11 at 20:34
add comment

Guake 0.4.4 && Ubuntu 12.04

Edit in file:

gksu gedit /usr/bin/guake

Line 826:

width = VALUE

Save file and restart Guake!

share|improve this answer
add comment

I found a simple hack.

  1. Open guake.
  2. Open all the workspaces (Super + S).
  3. Drag guake terminal from one screen to another.
  4. Open the desired screen.

This works for me always on Ubuntu 13.10. To adjust the size, just close and open guake again by pressing F12.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.