Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Problem

I recently upgraded from 13.04 to 13.10, and suddenly notification bubbles don't appear themed as usual in the upper right corner, but they appear as white text on blue background in the upper-left corner. It looks like this:

Unsuccesful attempts to fix it

  • I tried reinstalling unity, notify-osd, ubuntu-desktop removed notification-daemon which was installed, none of that fixes it.

  • In fact running ps aux | grep notify-osd shows that notify-osd isn't even running. But when I try to start it manually by running /usr/lib/x86_64-linux-gnu/notify-osd I get:

    ** (notify-osd:4618): WARNING **: Another instance has already registered org.freedesktop.Notifications
    
    ** (notify-osd:4618): WARNING **: Could not register instance
    
  • If I understand well, the instance is registered by the /usr/share/dbus-1/services/org.freedesktop.Notifications.service file, which right now contains:

    [D-BUS Service]
    Name=org.freedesktop.Notifications
    Exec=/usr/lib/x86_64-linux-gnu/notify-osd
    

    Renaming or deleting that file (and rebooting) has no effect whatsoever (and it is not recreated automatically).

  • This is not a duplicate of No notifications from notify-osd on 13.10 (and by the way I purged gnome-flashback-session along with notification-daemon)

Question(s)

How can I debug this? How can I get notifications to come back to normal?

If additional debug information is needed, I'll be happy to add it (just that I can't find any more).

share|improve this question
    
Have you tried turning it off and on again (rebooting)? Do you have xfce-notifyd installed or any notification daemon other than notify-osd? What does ps aux | grep osd and/or ps aux | grep noti show? –  dobey Nov 4 '13 at 16:12
    
Rebooting changes nothing. xfce-notifyd isn't installed (I don't of any other daemon); ps aux | grep osd gives nothing, and ps aux | grep noti shows [fsnotify_mark], update-notifier and /usr/lib/cups/notifier/dbus. –  Wehlutyk Nov 4 '13 at 16:38
    
In addition to what dobey said, have you installed any other desktop environments? Have you updated recently? Try running apt-get autoremove. What does it want to remove? –  Seth Nov 4 '13 at 16:39
    
I have i3wm installed (should I try purging+autoremoving that?). apt-get autoremove removed no packages. And the problem appeared right after upgrading from 13.04 to 13.10. Edit: sorry, misunderstood the "update" question. (Am updating+rebooting) –  Wehlutyk Nov 4 '13 at 16:43
1  
The problem is that notify-osd nor notification-daemon draw notifications in that manner, under any condition, afaik. I'd suggest filing a proper bug on Launchpad about it, as Ask Ubuntu is not the place for bug reports, or debugging them. –  dobey Nov 4 '13 at 17:39

2 Answers 2

up vote 10 down vote accepted

i3 is using "dunst" notification daemon, so you have to remove it in order to re-enable ubuntu notify-osd.

Execute following from terminal:

sudo apt-get purge dunst
killall dunst
notify-send "Hello"
share|improve this answer
    
thank you man ! –  vitalii Aug 19 at 11:45

I had the same problem because of i3. Purging all packages that were installed with i3 helped me:

sudo apt-get purge i3 i3-wm i3lock suckless-tools i3status dunst

I think (but I'm not sure) that the problem was with dunst package - according to it's description it is notification daemon too.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.