Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently installed Ubuntu on my retina Macbook Pro (following this great guide).

Everything works fine so far however the screen brightness / backlight cannot be adjusted neither by using the assigned key nor by any other means. I know, I'm not the first to address this problem, but all the suggested solutions I found so far did not work for me. I unsuccessfully tried the following:

  • Including Option RegistryDwords" "EnableBrightnessControl=1 in the Devices Section of /etc/X11/xorg.conf
  • the application xbacklight
  • I also haven't found any file such as mbp_backlight or apple_backlight on my system which probably would be a starting point.

I'm using the Nvidia-driver. (BTW: With the nouveau-driver, the keys to adjust the brightness work. However, with the nouveau driver Ubuntu does not resume from suspend mode)

Any suggestions what I can do? Thanks!

share|improve this question
    
I also tried the latest nvidia drivers 331.25 without success. –  pjvds Nov 9 '13 at 11:35

6 Answers 6

Well the most satisfying solution I found was to disable my discrete Nvidia-GPU with gfxCardStatus under OSX and to reboot into Ubuntu. However, this is not very elegant and therefore I'm still looking for similar ways in Ubuntu. So if anyone knows a way to disable the Nvidia GPU under Ubuntu let me know. I've tried bumblebee, however unsuccessfully. Apparently it's not compatible with my MacBook or MacBooks in general, as Mac don't use the Optimus technology. Honestly I have no real knowledge about all this stuff, I just want Ubuntu to run elegantly on my system.

share|improve this answer

I disable NVidia GPU using the cli

echo 'OFF' > /sys/kernel/debug/vgaswitcheroo/switch

To make this happen at startup, add the above line to /etc/rc.local

Make sure you have Intel drivers installed.

sudo apt-get install xserver-xorg-video-intel 

With this, Suspend, resume and adjusting screen brightness work like a charm.

The only problem that still remains unsolved is the box hangs during logoff / shutdown due to this bug (Need to force a shutdown by holding the power key for 5 seconds).

share|improve this answer

Try this.

  • Execute $ sudo gedit /etc/default/grub

  • Modify the line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" to:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"

  • Save the changes.

  • Execute $ sudo update-grub

  • Reboot.

Archlinux Wiki on brightness controls here.

share|improve this answer

if you want to use the backlight with the nvidia drivers, try running (as root):

setpci -v -H1 -s 00:01.00 BRIDGE_CONTROL=0

Then adjust the backlight using the gmux_backlight sysfs file:

echo 200 > /sys/class/backlight/gmux_backlight/brightness
echo 800 > /sys/class/backlight/gmux_backlight/brightness
share|improve this answer

I installed Ubuntu 13.10 on my 15" MacBook Pro 11,3 (Late 2013) with kernel 3.14.0-031400rc5-generic and the 331.49 Nvidia driver. My brightness control keys were not working either. Fix was to add this line to /etc/rc.local:

setpci -v -H1 -s 00:01.00 BRIDGE_CONTROL=0

Brightness control keys work now.

share|improve this answer
    
This works perfectly on my Macbook Pro 10,1 running Ubuntu 14.04 (kernel 3.13.0-32-generic) with Nvidia driver version 340.24. –  Boatzart Aug 6 at 17:13
    
This worked perfectly for me with Macbook Pro 11,3 (mid 2014) and Ubuntu 14.04. –  pcx Dec 11 at 6:16

Find video/graphics card in Ubuntu and Linux Mint

Run the command below in terminal to know what video card is used for the backlight/brightness:

ls /sys/class/backlight/

find graphics driver in Ubuntu

As you can see, the output for me is dell_backlight and intel_backlight. An indicator that the graphics card in use is Intel. Another way to find out the graphics card would be to go in System Settings->Details->Graphics. You can see the graphic card in use.

If your graphics card is Intel, you can proceed with the fix below. Fix brightness control issue with Intel card in Ubuntu and Linux Mint:

Open a terminal and create the following configuration file, if it does not exist:

sudo touch /usr/share/X11/xorg.conf.d/20-intel.conf

Now we need to edit this file. You can use any editor be it a terminal one or graphical.

sudo gedit /usr/share/X11/xorg.conf.d/20-intel.conf

Add the following lines to this file:

Section "Device"
        Identifier  "card0"
        Driver      "intel"
        Option      "Backlight"  "intel_backlight"
        BusID       "PCI:0:2:0"

EndSection

Save it. Log out and log in back. The brightness control should be working through function keys now:

Fix brightness control not working in Ubuntu 13.10

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.