Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I currently hard two hard drives, the first-booting drive with grub/Ubuntu (12.04) and the second drive with Win 7. However, Win 7 doesn't like being the second drive (it expects to be the first) and doesn't hibernate.

I found solutions which involve changing grub files (didnt work) and also setting the windows partition to be "boot" in GParted (also didnt work). The strangest thing is that this was raised as a bug fix in 2012 so I am confused why I still get this issue.

Anyway! Is there a way in which I can re-setup my system to avoid this problem? Both my OSes don't have much on them so I dont mind re-installing everything if it means I can hibernate my Win 7 and have both OSes on different drives.

I weren't sure if it was better that I avoid grub and use the Win 7 boot manager??

share|improve this question

2 Answers 2

Try installing Windows on your computer and then installing Ubuntu to run beside it. You will have the option of choosing either one at startup that way.

share|improve this answer
    
Thats what I have now (unless I am missing something?)? –  user997112 Nov 4 '13 at 14:34

make free allocated space by using mini partition on windows , then at the time of installing choose something else and then click on free space then in that make swap partition and root directory . thats what i do..

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.