Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an HP Pavilion Sleekbook that came with windows 8 pre-installed. I had trouble dual booting after installing ubuntu, so I disabled safeboot on bios and proceeded to try boot-repair, nothing happened.

No dual boot yet. So I tried to reinstall ubuntu, but without the manual partitioning. So I chose to erase ubuntu 13 and reinstall it. Instead it deleted all my HP recovery partitions and windows as well.

Here is the log of boot-repair.

http://paste.ubuntu.com/6354919/

Gparted and fdisk only show one partition:

/dev/sda1

I am wondering if you could suggest any way of recovering my windows partition and have a working windows 8 again?

I need some information there with urgency. If you could help me I will be welcome.

I am desperated. Thanks

share|improve this question
add comment

1 Answer 1

Your Boot Repair log clearly shows that your NTFS partitions are intact (they're /dev/sda1, /dev/sda4, and /dev/sda5. Except for the very latest version, fdisk is useless on GPT disks, and it will show just one partition (typically partition #1). Your report of GParted showing just one partition is more troubling, but you haven't shown the actual program output, so it could be you've misinterpreted something. You might want to post the output of sudo gdisk -l /dev/sda and/or sudo parted /dev/sda print to verify that your partitions are present. (You'll probably need to install gdisk from a package of the same name.)

Assuming that your Boot Repair log is accurate and up-to-date, my guess is that you've got a boot loader problem, not a partition problem. Your description of the nature of this problem is unclear, though. Broadly speaking, several solutions commonly work:

  • Disable Secure Boot -- You mentioned disabling "safeboot" in your question, so if you meant Secure Boot you've probably already done this. If not, though, see this brief description for some general information. Unfortunately, details vary greatly between computers.
  • Update your firmware -- Check with the manufacturer for any available firmware updates. These can fix bugs, which are rampant in the EFI world. I recommend doing this before trying the next two options; or if you put it off, try rEFInd and/or Boot Repair again after updating the firmware.
  • Test (and perhaps install) rEFInd -- My rEFInd boot manager can often help. You can try the USB flash drive or CD-R image (available from the rEFInd downloads page) without making any changes to your computer. If that boots both Linux and Windows, installing the Debian package in rEFInd should fix the problem. (A caveat, though: Some HPs have known EFI bugs that may require jumping through some extra hoops to get rEFInd to launch automatically. See here for details.)
  • Use Boot Repair -- Boot Repair can often fix boot problems; however, since you've already tried it and it didn't help, I wouldn't hold out too much hope. One additional thing is worth trying, though: Click the Advanced option and check the box to rename and replace the Windows boot loader file. This is helpful on buggy EFIs, such as some HPs are known to have, that refuse to launch boot loaders except from the filename that Windows uses for its boot loader.
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.