Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just set up a dual boot on an old HP computer and have upgraded to 12.04, but I am still having trouble getting connected wirelessly. Note: I have read many other posts with similar problems but none of their solutions have done the trick yet. I have gotten as far as being able to view wireless networks by virtue of installing atmel firmware, but no luck connecting still.

My router is WEP encrypted and a wireless-G router from Linksys, whereas my wireless USB adapter is wireless-B if that makes a difference. Any help is greatly appreciated!

Here are some outputs to help anyone get started with me:

When trying to connect to my network:

iwconfig
lo        no wireless extensions.

wlan0     IEEE 802.11b  ESSID:"Biokids"  
      Mode:Managed  Frequency:2.437 GHz  Access Point: 00:21:29:6B:35:38   
      Bit Rate=1 Mb/s   Tx-Power=20 dBm   
      Retry  long limit:7   RTS thr:off   Fragment thr:off
      Power Management:off
      Link Quality=42/100  Signal level=42/100  
      Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
      Tx excessive retries:0  Invalid misc:0   Missed beacon:0

eth0      no wireless extensions.

Shortly thereafter:

iwconfig
lo        no wireless extensions.

wlan0     IEEE 802.11b  ESSID:off/any  
      Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm   
      Retry  long limit:7   RTS thr:off   Fragment thr:off
      Power Management:off

eth0      no wireless extensions.

lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux    Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 002: ID 058f:9360 Alcor Micro Corp. 8-in-1 Media Card Reader
Bus 003 Device 006: ID 077b:2219 Linksys WUSB11 V2.6 802.11b Adapter
Bus 004 Device 002: ID 046d:c52b Logitech, Inc. Unifying Receiver

Please request/instruct as necessary.

share|improve this question
    
Is your router set to mixed mode 802.11b and g? Please see here: sim.dlink.ca/images/faqs/… –  chili555 Nov 4 '13 at 0:44
    
Yes, although the interface is slightly different. Wireless network mode is set to mixed, although there is no mention of 802.11b. Just like the images half way down the page here: justanswer.com/computer-networking/… Also, fwiw everything works fine and I can connect when I boot using windows. –  mgeorge Nov 4 '13 at 1:20
    
Are there any clues here? With the ethernet detached and as you are trying to connect: cat /var/log/syslog | grep -e wlan -e etwork | tail -n20. Please post here and give us the link: paste.ubuntu.com –  chili555 Nov 5 '13 at 14:51
    
Tried it out and got this: paste.ubuntu.com/6378930 –  mgeorge Nov 7 '13 at 22:41
    
I did it again and recorded it about every 10 seconds for a few rounds: paste.ubuntu.com/6378949 –  mgeorge Nov 7 '13 at 22:46

1 Answer 1

We see a lot of these entries in your logs:

ieee80211 phy0: wlan0: No probe response from AP xx:yy after 500ms, disconnecting.

You might set a longer wait time:

sudo -i
echo "options mac80211 probe_wait_ms=3000"  >> /etc/modprobe.d/mac80211.conf
exit

Sometimes, it also helps to set the correct reulatory domain; check yours:

sudo iw reg get

If yours is blank or incorrect for your country from here, then explicitly set it. http://en.wikipedia.org/wiki/ISO_3166-1_alpha-2

gksudo gedit /etc/rc.local

Right above exit 0, add the correct code:

iw reg set US

Of course, set your code if not US. Proofread, save and close gedit. Reboot and tell us if there is any improvement.

share|improve this answer
    
I ran the instructed code, but still no luck. Here is the result of the previous test: paste.ubuntu.com/6384454 –  mgeorge Nov 8 '13 at 21:27
    
The regulatory domain was successfully changed to US. Here are some results of a few other commands that may be useful:paste.ubuntu.com/6384504 –  mgeorge Nov 8 '13 at 21:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.