Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed a fresh copy of Ubuntu Server 12.04 and VirtualBox 4.3. I have set up a VM called "MediaServer" and tried to start it. I then get the following error:

Cannot open host device '/dev/sr0' for readonly access.
Check the permissions of that device ('/bin/ls -l /dev/sr0'):
Most probably you need to be member of the device group.
Make sure that you logout/login after changing the group settings of the current user (VERR_ACCESS_DENIED)

I have looked all over the Internet and have been unable to find a solution. Using Webmin, I tried changing the group settings so that my user name was in the vboxusers group, but that did not work either. I tried various other changes in group settings and none of them worked.

Also, I tried rebooting the server after the changes and that didn't work either.

I have been following a guide on how to set up an Ubuntu server from the website "linuxhomeserverguide.com" and when it came to the section where you could finally set up your first virtual machine, I am stumped. I would really appreciate it if someone could help me.

share|improve this question
1  
Is your user in the group cdrom? –  Takkat Nov 3 '13 at 22:30

1 Answer 1

Your user must be in the cdrom group.

sudo usermod -a -G cdrom $USER

Restart the system and try again.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.