Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I really wanted to dive into the world of Open Source operating systems, so I downloaded the latest version of Ubuntu (13.10), and installed it on a clean(no operating system installed, absolutely nothing) Lenovo ThinkPad machine.

After a few days, I wanted to try out a different Operating System (Elementary OS). I downloaded the ISO file, burned it to a USB, tested that the USB booted from a different computer (I have 2, one is the Lenovo, the other a HP). I was able to get the bootscreen, and everything worked like a charm after I set the BIOS to boot from USB Disk Drive instead of HD.

After this, I went back to Lenovo, and tried to open up the boot menu, by pressing F12, so that I could load from a temporary device.

To my surprise, nothing but the HD was listed. There was no Optical Drive, No USB Drive, absolutely nothing.

So, I thought that these devices were probably disabled. So I went into my BIOS and checked to see what was the case. I saw that all my devices were enabled. USB and all the other devices such as network cable and the rest were all enabled.

So, I thought this probably had something to do wit UEFI and Legacy Boot options. So, I made sure that both were enabled.

This did not solve the problem either. Again, I got nothing but the option to boot from my Hard Disk.

I thought the USB had to be at fault. I tried different ports, but to no avail. Next, I tried with a Live CD, which had Ubuntu on it. This failed too. I simply could not boot from anything other than my hard disk.

Okay, so at this point, I was pretty desperate, so I installed Boot-Repair through:

sudo add-apt-repository ppa:yannubuntu/boot-repair
sudo apt-get update
sudo apt-get install boot-repair

What this did is lead me to GRUB. Ideally, its just a screen that gives me the option to load from Ubuntu or Advanced Settings. The Advanced settings had nothing but Ubuntu options in it.

So, I kept on pressing ESC and that led me to the the grub console, and thats where I am right now with my Lenovo.

I've also tried updating the BIOS, but Lenovo only has packages for Red Hat and Windows. So, a dead end there too.

Right now, I need to know if there is any way that I can just delete everything from my Lenovo? I want to revert it back to its blank factory condition. How can I achieve this?

I have tried to elaborate my problem as best I could. If there is any important information that I've missed out, please do not hesitate to leave a comment. I would have included some screen shots, but BIOS screen shots are a little hard to manage. However, I can provide a camera Image of the boot screen if needed (doing that as we speak).

UPDATE

These are the pictures of my boot screen: enter image description here enter image description here

share|improve this question
    
The operating system is only on the Hard Disk. So to wipe the hard disk, use the Ubuntu Live CD (I presume that that works, otherwise you would not of been able to install), open up GParted and wipe the partitions. However this will remove all the data as well, and they would not be much point in it anyway as the elementary disk does not work. If the Ubuntu disk works, elementary should also work (it is based on Ubuntu anyway). If it is just the elementary disk, either try and make a new one, or try another OS, such as Fedora. –  Wilf Nov 3 '13 at 22:20
    
Are both boot disks (Ubuntu and Elementary) the same architecture (32 or 64 bit)? Are your laptops 32-bit or 64? You can install 32-bit on a 64-bit machine, but you can't install 64-bit on a 32-bit one. –  amc Nov 3 '13 at 22:50
    
You can try and update the BIOS if an update is available. See here, on how to get it done. –  Mitch Nov 4 '13 at 6:17
    
@wilf Tried using a Live USB, I used Linux Live, but that did not work. –  Games Brainiac Nov 4 '13 at 15:49
    
@amc Both are 64 bit. –  Games Brainiac Nov 4 '13 at 15:51
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.