Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using ubuntu 13.10 as htpc. To save some power, i have set it to suspend after 30minutes of inactivity. Before entering suspended state, a popup appears to warn me that computer is about to get put to sleep. This is a little annoyance since it appears when i resume the pc later.

How can i disable this notification for good?

share|improve this question
    
I'd also like to remove this -- it started happening with 13.10 and seems completely pointless as the notification only appears after the display has turned off (~10 minutes before suspending) and persists after waking up. –  serilain Nov 3 '13 at 17:46
1  
This is fixed in 14.04. The warning shows up as a desktop notification instead of a message box that needs to be cleared. –  chaskes Apr 1 at 1:33
add comment

1 Answer 1

One workaround posted on launchpad is a script that is based on the hooks of pm-utils:

sudo wget -O /etc/pm/sleep.d/20_kill-notify-osd https://bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/1232454/+attachment/3942236/+files/20_kill-notify-osd
sudo chmod +x /etc/pm/sleep.d/20_kill-notify-osd

Another workaround might be the following method:

Download a script and make it executable:

wget -O ~/.suspendwarning.sh https://bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/1232454/+attachment/3942095/+files/myscripts
chmod +x ~/.suspendwarning.sh

Add it to ~/.bashrc:

echo "if [ -f ~/.suspendwarning.sh ]; then
. ~/.suspendwarning.sh
fi" >> ~/.bashrc

After logging out and in the notifications should not pop up anymore after resume.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.