Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In Ubuntu 13.04 there was an option to use the PPA by Relan in order to get ExFat functionality. Seeing that in Ubuntu this functionality is now available from the repositories without the PPA I tried this but failed to make it work.

So my question is how do I enable exfat support?

Old Way

sudo apt-add-repository ppa:relan/exfat

sudo apt-get update

sudo apt-get install exfat-fuse exfat-utils

Tried now via Ubuntu Software Center

sudo apt-get install exfat-utils exfat-fuse

share|improve this question
    
Odly enough, when searching the term exfat in the software center I can still find the fuse-utils (after showing technical items) but after clicking on it, it says "Not found - There isn’t a software package called “fuse-exfat” in your current software sources." –  davorao Nov 3 '13 at 10:49

5 Answers 5

up vote 28 down vote accepted

Turns out the packages from the official repositories do the trick, as long as you do a restart after installing them. :)

Install exfat-utils and exfat-fuse packages from the official repos:

sudo apt-get install exfat-utils exfat-fuse

Reboot your computer:

sudo reboot

After reboot you will have a working exfat file system (read and write support, but not formatting the drives with exfat via Gnome Disks and GParted).

Thank you for all the suggestions, especially the PPA from relan, but the packages in that PPA are older than the ones in the official repositories. This might change when updates start coming in, as the PPA might include new releases more quickly.

share|improve this answer
5  
For me, this now works even without a reboot. Using Ubuntu 13.10 x64. –  Andrew Jan 10 at 16:50

Hi Finally get it to work on my 13.10.

I did:

    apt-add-repository ppa:relan/exfat

    sudo apt-get install fuse  (only fuse)

and lastly

    sudo apt-get install exfat-fuse   (instead of fuse-exfat)

Plugged my External HD and it's working read/write.

share|improve this answer
    
I'm not sure what's changed, but this seems to be no longer necessary as the official packages, exfat-utils and exfat-fuse work just fine for me. –  Andrew Jan 10 at 16:51
    
This worked for me in 14.04, thanks. –  badsyntax Apr 12 at 16:00
    
if you are formatting your own exfat volume, make sure to set the partition id to ntfs, not fat---otherwise, OSX will not recognize it. at least, this is what it took on my system. –  user1539216 Sep 1 at 16:18

fuse-utils moved to fuse. fuse-utils has been a trasitionary metapackage (something that just depends on the new package name) since 12.04.

That doesn't help you much if you have something that has a package dependency on fuse-utils because you're right, the metapackage has been removed now. The simplest thing to do might be to just download the Raring version and install that. It shouldn't hurt anything as it makes no demands on which version of fuse to install, just that there's one installed.

share|improve this answer
    
Hi @Oli I will try that. Thanks for the tip. Will write how it worked. –  davorao Nov 3 '13 at 10:55
    
@davorao If it's any consolation, it might be mainline (and not need fuse) by the next Ubuntu release. There already is a kernel driver but it's not quite ready yet, from what I can see. –  Oli Nov 3 '13 at 11:04
    
It is actually. The Raring version wouldn't quite want to work, so I will wait and see how it evolves over time. Thanks. :) –  davorao Nov 3 '13 at 11:05

I just did a successful install on 4/3/2014 with Ubuntu 13.10, fully updated, using only this command:

sudo apt-get update && sudo apt-get install exfat-utils

No restart required, and the drive auto-mounted with full read/write support.

share|improve this answer

To install exfat on Ubuntu 13.10 Saucy Salamander, you don’t need to add any extra PPA to your sources list. You only need exfat-utils package

$ sudo apt-get update && sudo apt-get install exfat-utils

Ubuntu and Linux Mint will not automatic mount exfat devince. To mount exfat device, plug in your device and run:

$ su -
# cat /proc/partitions
# cd /media
# mkdir usbdrive
# mount -t exfat /dev/sdd1 usbexfat

From http://namhuy.net/872/how-to-enable-exfat-on-ubuntu.html

share|improve this answer

protected by Community Sep 15 at 8:29

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.