Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In Ubuntu 13.04 there was an option to use the PPA by Relan in order to get ExFat functionality. Seeing that in Ubuntu this functionality is now available from the repositories without the PPA I tried this but failed to make it work.

So my question is how do I enable exfat support?

share|improve this question
    
Odly enough, when searching the term exfat in the software center I can still find the fuse-utils (after showing technical items) but after clicking on it, it says "Not found - There isn’t a software package called “fuse-exfat” in your current software sources." – davorao Nov 3 '13 at 10:49
    
possible duplicate of Is there a simple way to add exFAT support? – Galgalesh Nov 14 '14 at 21:08
up vote 150 down vote accepted

Turns out the packages from the official repositories do the trick. Just install exfat-utils and exfat-fuse packages using the package manager of your choice, or just using apt-get from the command line:

sudo apt-get install exfat-utils exfat-fuse

This should delivery a working exfat file system (read and write support, but not formatting the drives with exfat via Gnome Disks and GParted).

From 13.04+ it hasn't been necessary but if you're using 12.04 you might need to reboot your computer before you can mount your exfat partition. If it isn't working for you after installing the packages, try rebooting.

share|improve this answer
28  
For me, this now works even without a reboot. Using Ubuntu 13.10 x64. – Andrew Jan 10 '14 at 16:50
1  
Worked perfectly without reboot to get Ubuntu to recognize a Samsung T1 external SSD. Thanks! – friederbluemle Feb 4 '15 at 8:53
    
Works perfectly! No reboot required! If it doesn't want to work directly after the installation, then just unplug the drive and plug it back in... – alexander255 May 9 '15 at 21:09
    
I had to reboot, for 15.04. but It works great. – Mateo Jul 9 '15 at 4:32
    
Didn't have to reboot with Ubuntu 15.04. – Nathan Osman Jul 29 '15 at 17:32

Finally get it to work on my 13.10.

I did:

sudo apt-add-repository ppa:relan/exfat
sudo apt-get install fuse  # (only fuse)

and lastly

sudo apt-get install exfat-fuse   # (instead of fuse-exfat)

Plugged my External HD and it's working read/write.

share|improve this answer
    
I'm not sure what's changed, but this seems to be no longer necessary as the official packages, exfat-utils and exfat-fuse work just fine for me. – Andrew Jan 10 '14 at 16:51
    
This worked for me in 14.04, thanks. – badsyntax Apr 12 '14 at 16:00
1  
if you are formatting your own exfat volume, make sure to set the partition id to ntfs, not fat---otherwise, OSX will not recognize it. at least, this is what it took on my system. – user1539216 Sep 1 '14 at 16:18

I just did a successful install on 4/3/2014 with Ubuntu 13.10, fully updated, using only this command:

sudo apt-get update && sudo apt-get install exfat-utils

No restart required, and the drive auto-mounted with full read/write support.

share|improve this answer

fuse-utils moved to fuse. fuse-utils has been a trasitionary metapackage (something that just depends on the new package name) since 12.04.

That doesn't help you much if you have something that has a package dependency on fuse-utils because you're right, the metapackage has been removed now. The simplest thing to do might be to just download the Raring version and install that. It shouldn't hurt anything as it makes no demands on which version of fuse to install, just that there's one installed.

share|improve this answer
    
Hi @Oli I will try that. Thanks for the tip. Will write how it worked. – davorao Nov 3 '13 at 10:55
    
@davorao If it's any consolation, it might be mainline (and not need fuse) by the next Ubuntu release. There already is a kernel driver but it's not quite ready yet, from what I can see. – Oli Nov 3 '13 at 11:04
    
It is actually. The Raring version wouldn't quite want to work, so I will wait and see how it evolves over time. Thanks. :) – davorao Nov 3 '13 at 11:05

protected by Community Sep 15 '14 at 8:29

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.