Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I had Ubuntu 12.04 initially installed on my laptop. I upgraded to 12.10 then 13.04. Everything worked fine, including wireless. After adding a new memory card ( I only had 2 gb and one memory slot free) my wireess stopped working. I backed up all my data and reinstallled Ubuntu 13.04. Everything works fine except wireess. I bought this laptop in 2010 from Japan. It has Intel Core i5 CPU M 450 @2.40 Ghz * 4 3,7 Gb RAM os type 64 bit The output of iwconfig: eth0 no wireless extensions.

lo        no wireless extensions.


wlan0     IEEE 802.11bgn  ESSID:off/any  
      Mode:Managed  Access Point: Not-Associated   Tx-Power=15 dBm   
      Retry  long limit:7   RTS thr:off   Fragment thr:off
      Power Management:off 

The output of rfkill list all:

0: ideapad_wlan: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

The output of lshw -C network:

   *-network                      description: Wireless interface
   product: AR9285 Wireless Network Adapter (PCI-Express)
   vendor: Atheros Communications Inc.
   physical id: 0
   bus info: pci@0000:05:00.0
   logical name: wlan0
   version: 01
   serial: 78:e4:00:7d:fe:fa
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
   configuration: broadcast=yes driver=ath9k driverversion=3.8.0-19-generic                    firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
   resources: irq:17 memory:d6400000-d640ffff
  *-network
   description: Ethernet interface
   product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
   vendor: Realtek Semiconductor Co., Ltd.
   physical id: 0
   bus info: pci@0000:06:00.0
   logical name: eth0
   version: 02
   serial: 88:ae:1d:2b:36:ac
   size: 100Mbit/s
   capacity: 100Mbit/s
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical   tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full ip=192.168.2.2 latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
   resources: irq:41 ioport:2000(size=256) memory:d2410000-d2410fff memory:d2400000-d240ffff memory:d2420000-d243ffff

The wi-fi network appears as disconnected ( it's greyed out) Strangely enough I see a wifi network ( not mine) but not mine or the rest. That network doesn't require a password . I click on it, try to connect and i get an error message: failed to connect to xxxxx ... 32) The access point/org/freedesktop/NetworkManager/AccessPoint/0 was not in the scan list. Someone help please

share|improve this question
add comment

1 Answer

I've had same issue - it is VERY LOW LEVEL - see my post on it here:

( Partially Solved.. ) INFO ABOUT Wireless being GREYED OUT on Lubuntu 13.04, AFTER AN OS UPGRADE

Try that - wish you luck

share|improve this answer
    
Thank you very much for your answer. I tried everything you mentioned, in the right order. First the a,b,c,d steps.Nothing changed. Then I did rfkill list - nothing was blocked. un-ticked enable networking, ticked back...nothing. –  teyi Nov 16 '13 at 21:26
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.