Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I am using 13.10 for both the host and guest. The host has the guest additions iso. While installing the guest additions, I encounter an error when trying to compile the shared files module. The relevant log file /var/log/vboxadd-install.log shows the following:

 gcc -Wp,-MD,/tmp/vbox.0/.dirops.o.d  -nostdinc -isystem /usr/lib/gcc/x86_64-linux-gnu/4.8/include  -I/usr/src/linux-he
aders-3.11.0-12-generic/arch/x86/include -Iarch/x86/include/generated  -Iinclude -I/usr/src/linux-headers-3.11.0-12-gene
ric/arch/x86/include/uapi -Iarch/x86/include/generated/uapi -I/usr/src/linux-headers-3.11.0-12-generic/include/uapi -Iin
clude/generated/uapi -include /usr/src/linux-headers-3.11.0-12-generic/include/linux/kconfig.h -Iubuntu/include  -D__KER
NEL__ -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -Werror-implicit-function-declar
ation -Wno-format-security -fno-delete-null-pointer-checks -O2 -m64 -mno-sse -mpreferred-stack-boundary=3 -mtune=generic
 -mno-red-zone -mcmodel=kernel -funit-at-a-time -maccumulate-outgoing-args -fstack-protector -DCONFIG_X86_X32_ABI -DCONF
S_AVX2=1 -pipe -Wno-sign-compare -fno-asynchronous-unwind-tables -mno-sse -mno-mmx -mno-sse2 -mno-3dnow -mno-avx -Wframe
-larger-than=1024 -Wno-unused-but-set-variable -fno-omit-frame-pointer -fno-optimize-sibling-calls -pg -mfentry -DCC_USI
NG_FENTRY -Wdeclaration-after-statement -Wno-pointer-sign -fno-strict-overflow -fconserve-stack -DCC_HAVE_ASM_GOTO -fsho
rt-wchar -include /tmp/vbox.0/include/VBox/VBoxGuestMangling.h -I/lib/modules/3.11.0-12-generic/build/include -I/tmp/vbo
x.0/ -I/tmp/vbox.0/include -I/tmp/vbox.0/r0drv/linux -I/tmp/vbox.0/vboxsf/ -I/tmp/vbox.0/vboxsf/include -I/tmp/vbox.0/vb
ILD_BASENAME=KBUILD_STR(dirops)"  -D"KBUILD_MODNAME=KBUILD_STR(vboxsf)" -c -o /tmp/vbox.0/.tmp_dirops.o /tmp/vbox.0/diro
/tmp/vbox.0/dirops.c:292:5: error: unknown field ‘readdir’ specified in initializer
     .readdir = sf_dir_read,

I believe this may be relevant to Has anyone else encountered the same issue and is there a simple fix around it?

share|improve this question

3 Answers 3

up vote 3 down vote accepted

I had the same issue (see enter link description here).

On my side, the host is WindowsXP and the guest is Ubuntu 13.10. I was upgrading the guest from 13.04 to 13.10 and at the same time, I've upgraded VirtualBox from 4.2 to 4.3 (in the host).

I was trying to compile the Guest Extensions with

/etc/init.d/vboxadd setup

without success.

Then, I tried from the new Virtualbox ISO:

sudo /media/x/VBOXADDITIONS_4.3.2_90405/

It works :-)

I don't know how you tried to compile the guest additions, but maybe trying from the ISO will help you...

share|improve this answer

Same issue here, on Saucy 13.10 with VirtualBox 4.2.16 as available in the Software Center... fixed it by (first removing Ubuntu's outdated version) and then installing a 4.3.6 downloaded directly from

share|improve this answer
It seems there are a number of compatibility issues between the 3.11 kernel and virtualbox version < 4.3.2. Another one I ran into is I hope these things will get fixed in the repository when the recent version gets integrated. –  thenasko Jan 7 '14 at 23:07

Download the latest version of the VirtualBox iso here

OR automatically download it with this command

version=$(wget -qO- wget$version/VBoxGuestAdditions_$version.iso

Using the newest iso worked for me.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.