Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Dear Ubuntu Community,

I am having difficulties to get the WLAN Adapter on my Medion 98300 Laptop to work. The WLAN Card seems to be connected through an internal USB Interface and the Card itself had shown up as a wirelles Network while installing Ubuntu. I have tried a few things earlier, but none of my google reasearches have brought me to a working solution... I am quite new to the Linux System and only knoew a couple of terminal commands so far, so I probably have missed out on a few possible solutions. Maybe you can help me? Thank you very much in advance!

A few minimal technical details:

  • AMD Turion 64 X2 Dual-Core Mobile Technolgie TL-50
  • NVIDIA GeForce Go 6150
  • SanDisk 64GB SSD
  • 2GB RAM DDR2 667
  • nForce Chipset (I forgot the Version, but deductable from the GPU I guess)
  • WiFi: ZyDAS ZD1211B 802.11g

Thank's a lot again! :)

UPDATE: I tried around myself a little and found a guide on the Linux Mint forums that helped! I already had tried to install the linux backport modules etc. What I finally did was update the linux firmware and run the following command: echo "options acer_wmi wirelles=1" sudo tee /etc/modprobe.d/acer_wmi.conf and rebooted now I found and could connect to networks, but unfortunately I found, that the link quality was very bad, around 40 to 50. Eventhough my Router is running at high power and is only 6 Meters away! I then switched a few channels, but that did not improve much. Before, under Windows, I had a very good link quality and had the entire 16mbit/s internet connection at disposition, now I can only get about 3-5Mbit/s. better then nothing, but still pretty bad! The "TX power" is fixed on 20dBm and iwconfig says, that the "Power Management" is off... Maybe the power of the module is set too low?...

UPDATE2: I figured that 20dBm is a normal power output. I even tried to change the power using iwconfig wlan0 txpower INTEGERHERE but, obviously my "Card" does not support more then 20. More would probably be illegal as well, so I won't even use more then 20. I guess that I will have to figure out a way, or maybe just switch cards. Are the Mailboard-USB-Connectors on a laptop of the same property as the standard external ones? If so, I could simply solder a micro Wirelless N Adapter onto the board :)

UPDATE3: some further fiddling around seems to have improved it a bit, so that I got 14mbit/s at some point, but it's still pretty unstable! hm...

share|improve this question
1  
what version of ubuntu? 13.10 or 12.4? –  user204653 Nov 3 '13 at 8:58
    
Hello and thank's for your answer. I am using the 12.04 LTS. Is there a major change in 13.10? Oh and: I updated it using LAN, so, that's not a problem –  Anand Böhmer Nov 3 '13 at 10:21
    
I hope you actually meant: echo "options acer_wmi wireless=1" sudo tee /etc/modprobe.d/acer_wmi.conf instaed of wirelles. –  chili555 Nov 3 '13 at 15:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.