Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I purchased a set of spoken word audio CD's that have MP3 and FLAC audio files; I think they also play as regular audio CD's because I see a CDA directory and .cda files. But I'm only interested in playing the MP3 files by copying them to my phone.

Dolphin file manager shows all the files on the CD. However, it will not copy any of them to my hard drive, which is what my goal is. Dolphin shows no error, but the copy progress is zero.

Amarok will play the files but not easily. I only tried the flac files. To play a file, I click the file in Dolphin, then I have to cancel a job using KDE's notification system, then Amarok proceeds to copy the file to a tmp directory which takes a long time, then it finally plays.

kb3 will rip the audio, but I would prefer to copy the files directly from the CD.

Since Dolphin would not copy the files, I thought I would try the terminal, but I can't get that to work either.

mount -t auto -o ro /dev/sr0 /mnt/temp

that gives the error:

wrong fs type, bad option, bad superblock, etc.

I get the same error using -t iso9660 and -t udf.

so I started troubleshooting:

~$ wodim --devices
wodim: Overview of accessible drives (1 found) :
-------------------------------------------------------------------------
 0  dev='/dev/sg1'  rwrw-- : 'MATSHITA' 'DVD-RAM UJ8A0AS'
-------------------------------------------------------------------------

/dev/sg1 is not a block device

sudo file -s /dev/sr0
ERROR: cannot read /dev/sr0 (input/output error)

sudo file -s /dev/sg1 just hangs

How can I copy these files to my computer hard disk?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

As wodim says: you can't.
It has no real filesystem (it is not a block device) so you will have to rip it.

share|improve this answer
    
sometimes the files actually do copy, although very slowly. So I'm not fully satisfied with "you can't". –  MountainX Nov 7 '13 at 18:40
    
Technically you are right but ripping is exactly that: copying from a device without filesystem. Not every system is "smart" enough to handle that via copy and it is also very error prone. in other words: Don't copy from such a device if you can rip it. –  thom Nov 7 '13 at 23:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.