Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a bluetooth headset which works perfectly on Ubuntu 13.04. Now I update to 13.10, and here is what's happing:

After installing blueman, bluetooth-suport, pulseaudio-module-bluetooth and so on, I can find my device, pair it and connect to the headset service. But the device does not appear on the Sound Settings, so I just can't select it as input/output device. In other words, it's connected but "useless".

So, searching around for solutions, I found a software called stream2ip. With this I can connect the device and it appears on the Sound Settings, the sound plays on the device as well, but my microphone does not work, even when selected on the settings, also the A2DP option still not working.

Stream2ip isn't a solution at all, I mean everything was working without it in the previous Ubuntu version.

Maybe I'm missing something, and I hope someone could give me any hint.

How can I get the A2DP output option and the input working again, on the Ubuntu 13.10? How to make the device to appear on the Sound Settings without have to use Stream2ip?

Thanks!

Edit 1
What I tried so far:

  • Install bazaar fork related below.
  • Reinstall pulseaudio
  • Reinstall bluez
  • Change settings on /etc/bluetooth/audio.conf (Enable=Socket, Disable=Socket...)
  • Install all sort of packages like bluez-utils, bluez-audio, gstreamer0.10
  • Install pulseaudio volume control
  • Install blueman, bluetooth-suport, pulseaudio-module-bluetooth

Edit 2

Now the microphone and a2dp are working (separately of course).
To do this, I have to connect the headset, start some music, pause it using the playback options of the headset, then change the output mode in the sound settings to A2DP (sometimes it does not work in the first try)
It's far from working like it was working on 13.04. But it's working, and I probably will have to deal with the stream2ip for while.

By the way, here is how I installed the strem2ip:

sudo apt-add-repository ppa:takkat-nebuk/takkat
sudo apt-get update
sudo apt-get upgrade 
sudo apt-get install stream2ip-gtk3

Edit 3

Instead of using the stream2ip to make the headset appear on the sound settings, you can just use this command: pulseaudio -k

Now the question is: How to make it automatically when I pair my device?

What I got so far:

  • All the headset stuff working.
  • A way to avoid using the stream2ip, but not the optimal way yet.

Edit 4

When I disconnect my bluetooth device, the overall sound just crash, all the devices disappear from the sound settings (including the speakers). If open, the Rhythmbox also crashes and I don't have any other system sound as well.

Any guess on how to solve this?

And I'm still looking for ways to avoid using the pulseaudio -k command every time I connect my headset.

share|improve this question
    
by design microphone input will not work in a2dp mode. Stream2ip does not support HSP. See also askubuntu.com/questions/354383/… –  Takkat Nov 3 '13 at 10:19
    
Thanks for your comment. I'm sorry if my questions weren't clear. I don't want to use the Stream2ip because the bluetooth should work without it anyway. –  Eduardo Nov 3 '13 at 12:19
    
AD2P does not support a microphone. Nothing we can do about this, it is from Bluetooth design. For A2DP issues see Bug #1199059 - its not really stable at the moment –  Takkat Nov 3 '13 at 12:27
    
Yep, I'm sorry again if expressed myself poorly. I know that a2dp does not work with microphones. I have the "Telephony Duplex (HSP/HFP) mode", and this works with the microphone. At least it used to work on 13.04. Thanks for all your help anyway ;) –  Eduardo Nov 3 '13 at 18:26

3 Answers 3

Loading the bluetooth discovery module manually fixes the problem by now:

sudo pactl load-module module-bluetooth-discover

After loading the module everything works as expected.

share|improve this answer
    
Thanks for your answer! Yep, it works better by doing that, but after all, it is the same thing, I have to type a command to make it works. –  Eduardo Nov 30 '13 at 0:03

Maybe this helps

I suspect your bluetooth not working on 13.10 can be attributed to a bug in the latest kernel.

It can be fixed by installing a bazaar fork below:

https://code.launchpad.net/~robert-ancell/indicator-bluetooth/dont-hide-on-rfkill

Installation instructions are at:

How do I install a bazaar fork in 13.10?

The summary of commands to use:

sudo apt-get install bzr build-essential 
sudo apt-get build-dep indicator-bluetooth  
bzr branch lp:~robert-ancell/indicator-bluetooth/dont-hide-on-rfkill  
cd dont-hide-on-rfkill  
dpkg-buildpackage  
cd  
sudo dpkg -i indicator-bluetooth_0.0.6daily13.02.19-0ubuntu1_amd64.deb

Restart the system.

Details are at Bluetooth issues after Saucy upgrade

share|improve this answer
    
Thanks for replying! But unfortunately it doesn't work. I mean, I ran the commands without problems, but after reboot my issues still the same. –  Eduardo Nov 3 '13 at 11:56

I tried all the suggestions here to get my a2dp-mode with my bluetooth headphones to work in Ubuntu 13.10. After installation of Ubuntu 13.10 with kernel 3.12.rc4, the headphones were shown in sound-settings after pairing them and applying the command pulseaudio -k, which kills the pulseaudio-service. However, I still could not choose them and the sound kept playing over the internal speakers of the laptop.

This worked for me:

1) open configuration file

gksudo gedit /etc/bluetooth/audio.conf

and add under [General]:

Disable=Socket

I also uncommented the line (removing the #) that reads:

AutoConnect=true

2) reinstall pulseaudio and bluez, do NOT omit to install pulseaudio-module-bluetooth

sudo apt-get install --reinstall pulseaudio pulseaudio-utils pulseaudio-module-bluetooth
sudo apt-get install --reinstall bluez bluez-alsa bluez-audio bluez-gstreamer bluez-hcidump bluez-tools bluez-utils

Once I had done so, I restarted and connected by headphones using the bluetooth-settings, which worked fine. Still I did not see the headphones listed in sound-settings* in Unity. However, once I opened **pulseaudio-volume-control and selected the configuration-tab, I saw the headphones, but the associated profile was set to off. I changed that to A2DP and the headphones were listed in sound-settings. Since I done that, the headphones are shown in sound-settings immediately after connecting.

NOTE: I had the bazaar fork installed as described above, but removing it once the headphones connected did work.

share|improve this answer
    
Thanks for you answer! Unfortunately it didn't work for me. –  Eduardo Nov 30 '13 at 0:02
    
This made things worse for me on Trusty (14.04). Now I can't get A2DP at all. I guess I'm in fresh reinstall territory now :( –  Alain O'Dea Sep 18 at 13:01

protected by Community Mar 30 at 15:44

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.