Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed the IDE, following the instructions on your website. Than I went on to: http://developer.ubuntu.com/apps/qml/tutorial/

The tutorial says:

  1. In Qt Creator, press Ctrl+N to create a new project.
  2. Select the Projects -> Ubuntu -> Simple Touch UI template and click Choose…

...but a thing like that does not exist. The dialogue I get looks like this:

This is what the dialogue look like

I have tried to install the IDE, with or without the PPA, but I always get the same result.
And as it seems, I am not the only one with that problem: The other one

Is there a working way to install the SDK? Or at least a workaround? Something like installing the the templates separate?

share|improve this question
    
Make sure you are on 13.10 and that you have installed the package ubuntu-sdk directly, not the ppa. The webpage is a little behind. –  chaskes Nov 2 '13 at 23:31
    
huh? I do not understand that. I am using 13.10. But what do you mean by installing directly? –  Paholaisen Kysymys Nov 2 '13 at 23:42
    
what version of ubuntu are you using? how did you install qt-creator? –  chaskes Nov 2 '13 at 23:45
1  
yes, that was my point. if you are on 13.10, do not use the ppa. just install ubuntu-sdk directly. the web page instructions are outdated. –  chaskes Nov 2 '13 at 23:50
1  
So still the same problem. Can't do a thing. Hard to produce something beautiful, if you get smacked hard trying to take just the first step. –  Paholaisen Kysymys Nov 3 '13 at 0:35

1 Answer 1

up vote 1 down vote accepted

Yay, found the solution.

For some odd reason the Ubuntu SDK is installed in an unusable state. The IDE does not know the Qt version to use. To remedy the problem you have to follow the steps described in following answer:
Steps to set the right Qt version

Thanks for that well explained answer, to Majster-pl

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.