Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

Whenever I try to apt-get install a thing. This outputs:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 openjdk-7-jre : Depends: openjdk-7-jre-headless (= 7u25-2.3.10-1ubuntu0.12.10.2) but it is not going to be installed
                 Depends: libgif4 (>= 4.1.4) but it is not installable
                 Depends: libatk-wrapper-java-jni (>= 0.30.4-0ubuntu2) but it is not installable
                 Recommends: libgnome2-0 but it is not installable
                 Recommends: libgnomevfs2-0 but it is not installable
                 Recommends: libgconf2-4 but it is not installable
                 Recommends: ttf-dejavu-extra but it is not installable
E: Unable to correct problems, you have held broken packages.

How can I resolve this?

share|improve this question
1  
apt-get install what? –  Braiam Nov 2 '13 at 22:26
add comment

marked as duplicate by Radu Rădeanu, karel, Braiam, Avinash Raj, Alaa Jan 1 at 17:55

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer

to resolve the broken packages I beleave that sudo apt-get install -f should do the trick if it doesn't work take a look arrount at the oder suggestions here

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.