Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

It was working fine with windows 7.

The hardware switch is not disabled. I've toggled it back and forth dozens of times. The wifi light never turns on and it always lists as hardware disabled. I have the latest updates installed.

I've been searching for solutions, but none of them seem to work for me. I've tried removing acer-wmi. I've tried setting 11n_disable=1. I've tried resetting the bios. I've tried using rfkill to unblock (only removes soft block). I've rebooted dozens of times. The wifi light turns off as soon as grub loads.

Edit: I have a usb edimax wireless nic. It shows hardware disabled as well (although rfkill lists as unblocked). If I unload iwlwifi the usb nic works fine.

uname -a

`Linux xxx-Ideapad-Z570 3.2.0-55-generic #85-Ubuntu SMP Wed Oct 2 12:29:27 UTC 2013 x86_64 x86_64 x86_64 GNU/Linu`x

rfkill list

    19: phy18: Wireless LAN
        Soft blocked: no
        Hard blocked: yes

dmesg

[43463.022996] Intel(R) Wireless WiFi Link AGN driver for Linux, in-tree:
[43463.023002] Copyright(c) 2003-2011 Intel Corporation
[43463.023107] iwlwifi 0000:03:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[43463.023190] iwlwifi 0000:03:00.0: setting latency timer to 64
[43463.023253] iwlwifi 0000:03:00.0: pci_resource_len = 0x00002000
[43463.023257] iwlwifi 0000:03:00.0: pci_resource_base = ffffc900057c8000
[43463.023261] iwlwifi 0000:03:00.0: HW Revision ID = 0x0
[43463.023797] iwlwifi 0000:03:00.0: irq 43 for MSI/MSI-X
[43463.024013] iwlwifi 0000:03:00.0: Detected Intel(R) Centrino(R) Wireless-N 1000 BGN, REV=0x6C
[43463.024250] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[43463.045496] iwlwifi 0000:03:00.0: device EEPROM VER=0x15d, CALIB=0x6
[43463.045501] iwlwifi 0000:03:00.0: Device SKU: 0X50
[43463.045504] iwlwifi 0000:03:00.0: Valid Tx ant: 0X1, Valid Rx ant: 0X3
[43463.045542] iwlwifi 0000:03:00.0: Tunable channels: 13 802.11bg, 0 802.11a channels
[43463.045744] iwlwifi 0000:03:00.0: RF_KILL bit toggled to disable radio.
[43463.047652] iwlwifi 0000:03:00.0: loaded firmware version 39.31.5.1 build 35138
[43463.047823] Registered led device: phy18-led
[43463.047895] cfg80211: Ignoring regulatory request Set by core since the driver uses its own custom regulatory domain
[43463.048037] ieee80211 phy18: Selected rate control algorithm 'iwl-agn-rs'
[43463.055533] ADDRCONF(NETDEV_UP): wlan0: link is not ready

nm-tool

State: connected (global)

- Device: wlan0 ----------------------------------------------------------------
  Type:              802.11 WiFi
  Driver:            iwlwifi
  State:             unavailable
  Default:           no
  HW Address:        74:E5:0B:4A:9F:C2

  Capabilities:

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points 

lshw -C network

*-network DISABLED      
       description: Wireless interface
       product: Centrino Wireless-N 1000 [Condor Peak]
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: wlan0
       version: 00
       serial: 74:e5:0b:4a:9f:c2
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=3.2.0-55-generic firmware=39.31.5.1 build 35138 latency=0 link=no multicast=yes wireless=IEEE 802.11bg
       resources: irq:43 memory:f1500000-f1501fff

lspci

03:00.0 Network controller: Intel Corporation Centrino Wireless-N 1000 [Condor Peak]
share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.