Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to install MariaDB according to this documentation:

sudo apt-get install python-software-properties
sudo apt-key adv --recv-keys --keyserver hkp://keyserver.ubuntu.com:80 0xcbcb082a1bb943db
sudo add-apt-repository 'deb http://mirrors.fe.up.pt/pub/mariadb/repo/5.5/ubuntu precise main'
sudo apt-get update
sudo apt-get install mariadb-server

But faced with problem which is solved at this topic I'm using this command:

sudo apt-get install mariadb-server-5.5="5.5.33a+maria-1~saucy" 
mariadb-client 5.5="5.5.33a+maria-1~saucy" \libmysqlclient18="5.5.33a+maria-1~saucy" 
    \mysql-common="5.5.33a+maria-1~saucy"

Intead of saucy I've wrote precise but it doesn't help, I'm getting such errors:

    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Note, selecting 'mariadb-galera-server-5.5' for regex '5.5'
    Note, selecting 'mariadb-test-5.5' for regex '5.5'
    Note, selecting 'libghc-simpleea-dev-0.1.1-a1525' for regex '5.5'
    Note, selecting 'hl5150dlpr' for regex '5.5'
    Note, selecting 'libghc-haskelldb-prof-2.1.1-5a57e' for regex '5.5'
    Note, selecting 'libassa3.5-5-dbg' for regex '5.5'
    Note, selecting 'libassa3.5-5-dev' for regex '5.5'
    Note, selecting 'sword-text-gerlut1545' for regex '5.5'
    Note, selecting 'mariadb-server-5.5' for regex '5.5'
    Note, selecting 'mariadb-client-5.5' for regex '5.5'
    Note, selecting 'mariadb-server-core-5.5' for regex '5.5'
    Note, selecting 'cupswrapperhl5150d' for regex '5.5'
    Note, selecting 'libghc-http-conduit-prof-1.2.5-502c3' for regex '5.5'
    Note, selecting 'libghc-hdbc-sqlite3-prof-2.3.3.0-fe5b5' for regex '5.5'
    Note, selecting 'mysql-server-core-5.5' for regex '5.5'
    Note, selecting 'libghc-leksah-server-dev-0.12.0.4-45c55' for regex '5.5'
    Note, selecting 'mariadb-client-core-5.5' for regex '5.5'
    Note, selecting 'libghc-hdbc-sqlite3-dev-2.3.3.0-fe5b5' for regex '5.5'
    Note, selecting 'libghc-primitive-dev-0.4.1-50546' for regex '5.5'
    Note, selecting 'libghc-haskelldb-dev-2.1.1-5a57e' for regex '5.5'
    Note, selecting 'libghc-simpleea-prof-0.1.1-a1525' for regex '5.5'
    Note, selecting 'u-boot-linaro-smdk5250' for regex '5.5'
    Note, selecting 'libghc-void-prof-0.5.5-f4fcb' for regex '5.5'
    Note, selecting 'libassa3.5-5' for regex '5.5'
    Note, selecting 'netbeans5.5' for regex '5.5'
    Note, selecting 'handlersocket-mysql-5.5' for regex '5.5'
    Note, selecting 'libghc-void-dev-0.5.5-f4fcb' for regex '5.5'
    Note, selecting 'mysql-client-core-5.5' for regex '5.5'
    Note, selecting 'libghc-http-conduit-dev-1.2.5-502c3' for regex '5.5'
    Note, selecting 'libghc-bifunctors-prof-0.1.2-5156d' for regex '5.5'
    Note, selecting 'hl5050lpr' for regex '5.5'
    Note, selecting 'libghc-ansi-terminal-prof-0.5.5-3c75c' for regex '5.5'
    Note, selecting 'libghc-yesod-json-dev-0.3.1-85953' for regex '5.5'
    Note, selecting 'solr-tomcat5.5' for regex '5.5'
    Note, selecting 'cupswrapperhl5250dn' for regex '5.5'
    Note, selecting 'libghc-mime-mail-prof-0.4.1.1-ee5a5' for regex '5.5'
    Note, selecting 'libvirtuoso5.5-cil' for regex '5.5'
    Note, selecting 'libxmlplaylist-ocaml-dev-iq545' for regex '5.5'
    Note, selecting 'libghc-bifunctors-dev-0.1.2-5156d' for regex '5.5'
    Note, selecting 'libghc-mime-mail-dev-0.4.1.1-ee5a5' for regex '5.5'
    Note, selecting 'mysql-testsuite-5.5' for regex '5.5'
    Note, selecting 'libghc-primitive-prof-0.4.1-50546' for regex '5.5'
    Note, selecting 'mysql-source-5.5' for regex '5.5'
    Note, selecting 'libghc-yesod-json-prof-0.3.1-85953' for regex '5.5'
    Note, selecting 'cupswrapperhl5050' for regex '5.5'
    Note, selecting 'libghc-ansi-terminal-dev-0.5.5-3c75c' for regex '5.5'
    Note, selecting 'mysql-server-5.5' for regex '5.5'
    Note, selecting 'brhl5250dnlpr' for regex '5.5'
    Note, selecting 'cupswrapperfax5750e' for regex '5.5'
    Note, selecting 'mysql-client-5.5' for regex '5.5'
    Note, selecting 'fax5750elpr' for regex '5.5'
    E: Version '5.5.33a+maria-1~precise' for 'mysql-server-core-5.5' was not found
    E: Version '5.5.33a+maria-1~precise' for 'mysql-client-core-5.5' was not found
    E: Version '5.5.33a+maria-1~precise' for 'mysql-client-5.5' was not found
    E: Version '5.5.33a+maria-1~precise' for 'mysql-server-5.5' was not found
    E: Version '5.5.33a+maria-1~precise' for 'libassa3.5-5' was not found
    E: Version '5.5.33a+maria-1~precise' for 'handlersocket-mysql-5.5' was not found
    E: Version '5.5.33a+maria-1~precise' for 'libassa3.5-5-dbg' was not found
    E: Version '5.5.33a+maria-1~precise' for 'libassa3.5-5-dev' was not found
    E: Version '5.5.33a+maria-1~precise' for 'libghc-void-dev-0.5.5-f4fcb' was not found
    E: Version '5.5.33a+maria-1~precise' for 'libghc-void-prof-0.5.5-f4fcb' was not found
    E: Version '5.5.33a+maria-1~precise' for 'libghc-ansi-terminal-dev-0.5.5-3c75c' was not found
    E: Version '5.5.33a+maria-1~precise' for 'libghc-ansi-terminal-prof-0.5.5-3c75c' was not found
    E: Version '5.5.33a+maria-1~precise' for 'libghc-http-conduit-dev-1.2.5-502c3' was not found
    E: Version '5.5.33a+maria-1~precise' for 'libghc-http-conduit-prof-1.2.5-502c3' was not found
    E: Version '5.5.33a+maria-1~precise' for 'libghc-bifunctors-dev-0.1.2-5156d' was not found
    E: Version '5.5.33a+maria-1~precise' for 'libghc-bifunctors-prof-0.1.2-5156d' was not found
    E: Version '5.5.33a+maria-1~precise' for 'libghc-primitive-dev-0.4.1-50546' was not found
    E: Version '5.5.33a+maria-1~precise' for 'libghc-primitive-prof-0.4.1-50546' was not found
    E: Version '5.5.33a+maria-1~precise' for 'libghc-haskelldb-dev-2.1.1-5a57e' was not found
    E: Version '5.5.33a+maria-1~precise' for 'libghc-haskelldb-prof-2.1.1-5a57e' was not found
    E: Version '5.5.33a+maria-1~precise' for 'libghc-hdbc-sqlite3-dev-2.3.3.0-fe5b5' was not found
    E: Version '5.5.33a+maria-1~precise' for 'libghc-hdbc-sqlite3-prof-2.3.3.0-fe5b5' was not found
    E: Version '5.5.33a+maria-1~precise' for 'libghc-leksah-server-dev-0.12.0.4-45c55' was not found
    E: Version '5.5.33a+maria-1~precise' for 'libghc-mime-mail-dev-0.4.1.1-ee5a5' was not found
    E: Version '5.5.33a+maria-1~precise' for 'libghc-mime-mail-prof-0.4.1.1-ee5a5' was not found
    E: Version '5.5.33a+maria-1~precise' for 'libghc-simpleea-dev-0.1.1-a1525' was not found
    E: Version '5.5.33a+maria-1~precise' for 'libghc-simpleea-prof-0.1.1-a1525' was not found
    E: Version '5.5.33a+maria-1~precise' for 'libghc-yesod-json-dev-0.3.1-85953' was not found
    E: Version '5.5.33a+maria-1~precise' for 'libghc-yesod-json-prof-0.3.1-85953' was not found
    E: Version '5.5.33a+maria-1~precise' for 'libxmlplaylist-ocaml-dev-iq545' was not found
    E: Version '5.5.33a+maria-1~precise' for 'libvirtuoso5.5-cil' was not found
    E: Version '5.5.33a+maria-1~precise' for 'solr-tomcat5.5' was not found
    E: Version '5.5.33a+maria-1~precise' for 'mysql-source-5.5' was not found
    E: Version '5.5.33a+maria-1~precise' for 'mysql-testsuite-5.5' was not found
    E: Version '5.5.33a+maria-1~precise' for 'netbeans5.5' was not found
    E: Version '5.5.33a+maria-1~precise' for 'sword-text-gerlut1545' was not found
    E: Version '5.5.33a+maria-1~precise' for 'cupswrapperhl5250dn' was not found
    E: Version '5.5.33a+maria-1~precise' for 'cupswrapperfax5750e' was not found
    E: Version '5.5.33a+maria-1~precise' for 'cupswrapperhl5050' was not found
    E: Version '5.5.33a+maria-1~precise' for 'cupswrapperhl5150d' was not found
    E: Version '5.5.33a+maria-1~precise' for 'brhl5250dnlpr' was not found
    E: Version '5.5.33a+maria-1~precise' for 'fax5750elpr' was not found
    E: Version '5.5.33a+maria-1~precise' for 'hl5050lpr' was not found
    E: Version '5.5.33a+maria-1~precise' for 'hl5150dlpr' was not found
    E: Version '5.5.33a+maria-1~precise' for 'u-boot-linaro-smdk5250' was not found

How can I fix it and install MariaDb?

share|improve this question
    
did you try this askubuntu.com/questions/64772/how-to-install-mariadb –  Avinash Raj Nov 5 '13 at 17:17
    
@AvinashRaj Yes, it was not working for me :( I've installed MariaDB 10 –  viakondratiuk Nov 6 '13 at 8:05

1 Answer 1

This is how I managed to install it:

sudo aptitude install mariadb-server libmysqlclient18=5.5.33a+maria-1~precise mysql-common=5.5.33a+maria-1~precise
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.