Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

0 down vote favorite

I am running a JNativeHook capture program on Ubuntu. When I run the session on default X session things are working fine. However when I run the same program from vnc session, it fails with "Xlib: extension "RECORD" missing on display".

I checked that this extension is loaded in X which is started by display manager/init. However I am not sure if indeed is initialized during vncserver startup. I could not see anything related in the vnc log.

I tried create custom xorg.conf with Module section, which explicitly loads RECORD extension as suggested by many posts but did not help.

My environment: Xorg-server: 2.1.12.4-6 tightvncserver: 1.3.9

The same thing works fine on my CentOS 6.4 setup.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.