Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In Ubuntu 13.10, the hotkeys/shortcut-keys (Ctrl+B, Ctrl+S etc) in LibreOffice are language dependent and work in English language only. While writing in any other language (i.e. any Cyrillic and/or any Bengali etc) it's impossible to use hotkeys, they just don't do anything. Switching to English input language enable hotkeys once again. This is very frustrating as user needs to switch language to save document, to make it bold, or italic, etc. This was not experienced in Ubuntu 13.04.

Steps to reproduce:

  1. System Settings > Text Entry.
  2. Add another keyboard layout beside English [In my case it is Bengali (Probhat)]
  3. Now launch Writer.
  4. Switch the keyboard layout from English (US) to Bengali (Probhat) by pressing Ctrl+Space.
  5. Press Ctrl+B to change font weight to bold.

Error: Font weight does not get changed.

Expected: Font weight should change to bold.

Note: none other system hotkeys work as expected. I.e. Ctrl+S to save, or Ctrl+B to subscript, or Ctrl+I to italic etc.

Workaround: The only way is to -

  1. change the keyboard layout to English
  2. then press desired hotkey
  3. then switch keyboard layout back to Bengali.

The issue is critical, as it make writer very slow for keyboard-only typing.

share|improve this question
add comment

2 Answers 2

It is a bug, see here: https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1246583 Should be fixed in next version

I can add I have the same issue in UBUNTU 13.10 with Apache openoffice 4.0.1

EDIT: It has now been fixed in the new LibreOffice beta 4.2 version. It can be downloaded from the Libreoffice website.

share|improve this answer
add comment

I seems that on LibreOffice 4.2, on 13.10 the bug still exists. I posted a workaround here

Using 13.10, Libreoffice 4.2, Gnome desktop

re configure keyboard settings using sudo dpkg-reconfigure keyboard-configuration then Alt+Shift key combination for changing layout works again.

This causes the following affects:

In LibreOffice: Press Super+Space: language changes, gnome language change displays on center screen, top bar display changes, hotkeys in when in Hebrew layout don't work. Press Alt+Shift: language changes, top bar display changes, hotkeys when in Hebrew do work.

But - when using Thunderbird I have this behavior:

Press Super+Space: language changes, gnome language change displays on center screen, top bar display changes, hotkeys work fine on both layouts. Press Alt+Shift: top bar display changes language, hotkeys work fine, but language does not change back to Hebrew (keeps typing in English even when top bar displays Hebrew).

So the workaround is as follows:

In LibreOffice - use Alt+Shift

In Thunuderbird - use Super+Space.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.