Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I shutdown my computer there is some annoying delay, it takes about 5-10 seconds in 13.10 when in the previous version it was almost instantaneous.

During shutdown I press escape to cancel the splash screen and can see that a big part of the delay is after "Asking all remaining process to terminate...", and then there is "Killing all remaining processes". I have filmed the process with my video camera to check which processes had to be killed, but they didn't chat anything to the terminal.

I previously had this same issue in 11.10, and I resolved it as answered here, however this did not work for me in 13.10.

How to identify the cause of delays in the shutdown process, and fix them?

share|improve this question

3 Answers 3

up vote 2 down vote accepted

Turn on reporting for misbehaving applications:

  1. Open /etc/init.d/sendsigs in your favourite text editor, with root privileges (e.g sudo vi /etc/init.d/sendsigs or gksu /etc/init.d/sendsigs). Search for the line #report_unkillable and uncomment it (i.e. remove the # tag). Save the file.

  2. Make sure that apport is enabled: Edit the file /etc/default/apport so it reads enabled=1. (If it was enabled=0 then reboot, so apport can start.)

  3. Shutdown.

  4. Upon the next boot apport should come up with a message telling you that there was some kind of problem with a program. That is the one causing the delay. And there should be a crash report in /var/crash . (If apport doesn't report the name, then just look in the crash file, in the end of the file there will be something like Title: MISBEHAVING_PROGRAMNAME does not terminate at computer shutdown)

share|improve this answer
    
I get a report about /sbin/initctl (initctl does not terminate at computer shutdown) –  wim Dec 15 '13 at 16:10
    
Here is a bug report (not really usefully informational, but it does show that at least one other person has had this problem and reported it): bugs.launchpad.net/ubuntu/+source/upstart/+bug/1261177 –  Atari911 Dec 15 '13 at 17:33
    
That is my bug report :) –  wim Jan 12 at 12:42

Have you tried this? Open terminal and type

sudo shutdown now

This might help.

share|improve this answer
1  
Thanks, but it didn't give me any more information than I already saw by checking the output with a video camera –  wim Nov 11 '13 at 17:29

Is the shutdown always slow or can it vary? If the latter is the case, what did you do before shutting down? Did you do something that took a lot of disk-writes that perhaps need to end first before all processes can be terminated?

you could save a list of all processes before shutting down as per:

ps -A > processes.txt

before you shutdown.

You could take a look at any errors that might have occurred after restart as per:

dmesg |tail

Hope this helps

Frank

share|improve this answer
    
it is slow everytime, even on a fresh boot –  wim Nov 28 '13 at 11:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.