Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running ubuntu 13.10 x86_64 and I have modified /etc/fstab to mount my NTFS HDD with permissions but I'm getting some permissions errors because the owner is "root" instead of my user.

Thanks in advance

P.S: I had no problems doing this in Ubuntu 13.04 32bits

EDIT:

fstab content:

#/etc/fstab: static file system information.

#Use 'blkid' to print the universally unique identifier for a
#device; this may be used with UUID= as a more robust way to name devices
#that works even if disks are added and removed. See fstab(5).

#<file system> <mount point>   <type>  <options>       <dump>  <pass>
#/ was on /dev/sda5 during installation
UUID=3e857b61-2d2b-469a-a3eb-de1cf4d5130a /               ext4    errors=remount-ro 0       
#/home was on /dev/sda7 during installation
#UUID=14887804-6799-443e-955f-6b2872cd441a /home           ext4    defaults        0       2
#swap was on /dev/sda6 during installation
#UUID=2da59282-61ee-40d2-821b-2042ff556748 none            swap    sw              0       0
#UUID=4A1499C11499B085 /media/ivykoko/269Gb ntfs umask=0000,utf8 0 0 
share|improve this question
    
Please post /etc/fstab content. –  Web-E Nov 1 '13 at 14:08
add comment

1 Answer 1

up vote 0 down vote accepted

To mount the drive with your user as the owner add the uid option.

Type id in the terminal to get your user ID from the output: uid=####.

Then add that option to fstab so your new entry will look like:

UUID=4A1499C11499B085 /media/ivykoko/269Gb ntfs umask=0000,utf8,uid=#### 0 0

Where #### is your actual uid.

Then unmount and remount the drive.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.