Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am new Ubuntu user My Laptop is "Vaio VPCEB1M0E "

I couldn't install the printer "Brother DCP-J140W", and I tried all the steps in this related questions and topics 1,2, and 3.

When I did the steps in the last link I was able to install the driver but I can't see the printer Icon in the Printers window ! and in the terminal I saw this lines :

molham@molham-VPCEB1M0E:~/Downloads$ sudo dpkg -i --force-all dcpj140wlpr-1.1.3-6.i386.deb
(Reading database ... 180721 files and directories currently installed.)
Preparing to replace dcpj140wlpr:i386 1.1.3-6 (using dcpj140wlpr-1.1.3-6.i386.deb) ...
Unpacking replacement dcpj140wlpr:i386 ...
Setting up dcpj140wlpr:i386 (1.1.3-6) ...
mkdir: cannot create directory `/var/spool/lpd/dcpj140w': No such file or directory
chown: cannot access `/var/spool/lpd/dcpj140w': No such file or directory
chgrp: cannot access `/var/spool/lpd/dcpj140w': No such file or directory
chmod: cannot access `/var/spool/lpd/dcpj140w': No such file or directory
molham@molham-VPCEB1M0E:~/Downloads$ dpkg  -l  |  grep  Brother4

To be honest I ignored this and continued the progress and this is the rest of the results :

molham@molham-VPCEB1M0E:~/Downloads$ sudo dpkg  -l  |  grep  Brother
ii  dcpj140wlpr:i386                            1.1.3-6                                 Brother lpr Inkjet Printer Definitions
ii  printer-driver-ptouch                       1.3-3ubuntu0.1                          printer driver Brother P-touch label printers

molham@molham-VPCEB1M0E:~$  cat /etc/printcap
DCPJ140W:\
       :mx=0:\
       :sd=/var/spool/lpd/dcpj140w:\
       :sh:\
       :lp=/dev/usb/lp0:\
       :if=/opt/brother/Printers/dcpj140w/lpd/filterdcpj140w:

Please ! any one can help me to know what should I do?

share|improve this question
    
I just removed the package and I'll try again !! –  Molham Haddad Nov 1 '13 at 6:53

1 Answer 1

Hoi,

I solved my problems and the printer/scanner DCP-j140(wifi) is working well unther Linux Mint 13 (Maya LTS = "Ubuntu"):

I installed it unther a plain/fresh Mint installation. So first You have to remove the not working printer(s) within the system...

Then You have to download the drivers: http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/download_prn.html

Select the Brother DCP-j140w drivers. They should result in the directory Downloads with the following 2 deb files:

dcpj140wcupswrapper-1.1.3-6.i386.deb

dcpj140wlpr-1.1.3-6.i386.deb

Use bv/ag. the Clamtk anti-virus tool to check these .deb files against viruses or malware. Hence! You downloaded them outside the protected area. (Also use the rkhunter...)

( sudo apt-get install clamtk

sudo apt-get install rkhunter

sudo rkhunter --update

sudo rkhunter --propupd

and scan with sudo rkhunter --check --sk

Probebly the rkhunter will react with some false "positives", so don't panic. Check them out with Google. This is my rkhunter result:

System checks summary

File properties checks... Files checked: 139 Suspect files: 1

Rootkit checks... Rootkits checked : 245 Possible rootkits: 0

Applications checks... All checks skipped

The system checks took: 1 minute and 55 seconds

All results have been written to the log file (/var/log/rkhunter.log)

One or more warnings have been found while checking the system. Please check the log file (/var/log/rkhunter.log)

Look at this result: Possible rootkits: 0 It always should be zero. If it is not zero then You've got a serious problem. You have to shutdown and install Linux "fresh" again.

)

Then start a console, the "DOS"-enviroment of Linux... From here copy/paste all letterly:

sudo apt-get install tcsh

cd Downloads

sudo mkdir /var/spool/lpd

sudo dpkg -i --force-all dcpj140wlpr-1.1.3-6.i386.deb

sudo dpkg -i --force-all dcpj140wcupswrapper-1.1.3-6.i386.deb

Linux/Mint/Ubuntu installed the USB-version of the DCP-j140w. With:

dpkg -l | grep Brother

You should get a output like this:

ii dcpj140wcupswrapper 1.1.3-6 Brother CUPS Inkjet Printer Definitions

ii dcpj140wlpr 1.1.3-6 Brother lpr Inkjet Printer Definitions

ii printer-driver-ptouch 1.3-3ubuntu0.1 printer driver Brother P-touch label printers

Go to System/Hardware/Printer-configuration:

And You see the usb-version of the DCP-j140w installed. In the URI You see the USB-link...

If this printer was working well unther Windows/Android, it should work unther Linux as well...

Go to New Printer and wait until You see something like this:

dnssd://Brother%20DCP-J140W._printer._tcp.local/

Select that one and delete the all the previous versions of the J140W.

After that select printing a testpage:

Within Wifi it should print an Ubuntu testpage...

And now the scanner:

You have to download the scanner .deb files first on:

http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/download_scn.html

Find them in the Downloads dir, named as:

brscan4-0.4.2-1.i386.deb

brscan-skey-0.2.4-1.i386.deb

Again: They are downloaded out of the secured enviroment. Check them first.

I can't say this often enough... On internet thrust nobody, only You're selves.

On Linux Mint Xsane is installed properly. If not You have to install Xsane first: sudo apt-get install xsane would do. Don't ask, copy/paste and execute...

Then type (copy/paste):

sudo dpkg -i brscan4-0.4.2-1.i386.deb

sudo dpkg -i --force-all brscan-skey-0.2.4-1.i386.deb

To check out:

dpkg -l | grep Brother

brscan-skey

Then whe have to find out the IP-address of ou're printer.

Therefore whe install this:

sudo apt-get install nmap zenmap

To check out: sudo nmap 192.168.1.*

Look for the ip-address where in is a item like this: xxx/tcp open printer. That's the right one. Note that ip-address: that's Your'e printer. All right!!!

Or use Zenmap (in root/sudo:)

If whe know the ip-address of the printer whe finally end with:

brsaneconfig4 -a name=SCANNER model=DCP-j140w ip=xxx.xxx.xxx.xxx (Where xxx = the ip-address of the printer.

Startingup Xsane should now work properly.

Enjoy working with You're Wifi printer/scanner,

Greetings, Grasjap

share|improve this answer
    
Thank you I was able to install the Printer and the scanner already but the information that you gave regarding the anti virus and the rootkits was very helpful –  Molham Haddad Jun 19 at 1:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.