Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've decided to switch to Dvorak on my Ubuntu machine, but I'm having some trouble:

First, I attempted to do this through the GUI -- System Settings -> Keyboard Layout -> add layout (plus sign) -> English(programmer Dvorak). This didn't work at first, so I restarted my machine. It seemed to work at the password prompt (if only because QWERTY did not), but I couldn't get it to accept my password. I used the virtual keyboard option to enter my password with mouse clicks (the virtual keyboard was using the programmer's Dvorak Standard) and was able to get in that way. Once logged in, however, I was back to QWERTY.

Second, I tried to switch on the command prompt -- $ loadkeys /usr/lib/kbd/keytables/dvorak.map The error message I received was "Couldn't get a file descriptor referring to the console "

Does anyone know what I'm doing wrong? I've looked for a solution for these problems, but couldn't find anything.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

I found the error. It was my .Xmodmap file. Once deleted, the GUI approach worked.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.