Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am unable to install anything on my Ubuntu server. When I do, i get the suggestion to run apt-get -f install

When I try running apt-get -f install I get:

apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  python-gnupginterface python-zope.interface
The following NEW packages will be installed:
  python-gnupginterface python-zope.interface
0 upgraded, 2 newly installed, 0 to remove and 61 not upgraded.
2 not fully installed or removed.
Need to get 0 B/133 kB of archives.
After this operation, 692 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Global symbol "$bundling" requires explicit package name at /usr/share/perl/5.14/Getopt/Long.pm line 77.
Global symbol "$bundling" requires explicit package name at /usr/share/perl/5.14/Getopt/Long.p line 84.
BEGIN not safe after errors--compilation aborted at /usr/share/perl/5.14/Getopt/Long.pm line 208.
Compilation failed in require at /usr/share/perl5/Debconf/Config.pm line 173.
dpkg: error: parsing file '/var/lib/dpkg/status' near line 5912 package 'libboost-iostreams1.46.1':
 'Depends' field, reference to 'zlib1g': error in version: epoch in version is not number
E: Sub-process /usr/bin/dpkg returned an error code (2)

and if I try running dpkg --configure -a I get:

dpkg --configure -a
Setting up gconf2 (3.2.5-0ubuntu2) ...
XXX lineno: 400, opcode: 0
Traceback (most recent call last):
  File "/usr/lib/python2.7/site.py", line 68, in <module>
    import os
  File "/usr/lib/python2.7/os.py", line 49, in <module>
    import posixpath as path
  File "/usr/lib/python2.7/posixpath.py", line 17, in <module>
    import warnings
  File "/usr/lib/python2.7/warnings.py", line 400, in <module>
    del _warnings_defaults
SystemError: unknown opcode
dpkg: error processing gconf2 (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of libcanberra-gtk-module:i386:
 libcanberra-gtk-module:i386 depends on gconf2 (>= 2.28.1-2); however:
  Package gconf2 is not configured yet.
dpkg: error processing libcanberra-gtk-module:i386 (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:

I have no idea where to go from here and would greatly appreciate any help anyone has to offer.


share|improve this question

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.