Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've recently installed Ubuntu 12.04 on some friend machine. He's migrating from Windows XP, and i'm his guide.

Right now he's having a problem with some youtube videos.

http://www.youtube.com/watch?v=7ABNUSndcnI

All the videos from that yt user seems to have the same trouble. Problem is, when going to full screen, my friend sees this:

image

So i try the video here, on my job's PC, were also have Ubuntu 12.04, and see it fine.

I ask him about the browser. Google Chrome. Ask him then to try Firefox, and says that in Firefox it works fine. I'm on Firefox too.

When i try the video on Chrome here on my job, i do see it ok in fullscreen, BUT, i notice that Chrome takes a few seconds to actually maximize it. That is, it's costly for Chrome to go fullcreen. Then try another video from another youtube user in Chrome, and it goes fullscreen fine.

So, something's wrong with those videos. As i go everywhere installing Ubuntu, and have no idea of what is going on here, i would like to learn what is happening here.

My friend has a nVidia GEForce 9800 GT with 319 drivers. I have an old legacy ATI here on my job.

Any clue?

share|improve this question

closed as off-topic by dobey, Lucio, Eric Carvalho, qbi, psusi Nov 3 '13 at 16:31

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems with the development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – dobey, Lucio, Eric Carvalho, qbi, psusi
If this question can be reworded to fit the rules in the help center, please edit the question.

    
Had a look, it could be just the quality of the video is too high for that computer (HD 720p / 1080p). Try another HD video like this to see if that is just the problem. Most Youtube videos are not HD, so might not present any problems. Also, update his computer using apt-get or something. –  Wilf Oct 31 '13 at 18:45
    
Hi wilf. I don't think it's quality. As said, he has a decen gpu with latest drivers and, as you can see, he plays heavy games with it. Also, everything's up to date: installed Ubuntu two days ago, and apt-upgrade'd the full system this very morning. –  Daniel Cantarin Oct 31 '13 at 18:53
    
No, but I find that Chrome is pretty useless with HD flash videos - like you said in the question, takes ages to fullscreen etc. I alos prefer Firefox for that sort of thing, one reason being that I can use this extension much better than in Chrome. Besides, I find that the integrated Intel graphics works much better for just using Flash and the Internet. Happy Halloween. –  Wilf Oct 31 '13 at 18:57
    
Well, that's interesting. However, i've checked it out in this machine (my job) and the video with hard-time-maximizing in chrome is in 320. No HD involved. –  Daniel Cantarin Oct 31 '13 at 19:25
    
That seems more an issue about flash/pepperflash + nvidia + nvidia drivers. He should try to install privative drivers (or rollback to free ones). In such cases is just keep trying until you find the correct one. Please, add the output of sudo lspci -nnk | grep -A7 VGA of the system that has problems. –  Braiam Nov 2 '13 at 1:03

3 Answers 3

up vote 1 down vote accepted

Finally, i've solved this.

I have no idea yet what's so special about those videos. However, by trial and error, i tested on my friend's machine some other screen resolutions, and saw that the one he was using was the only one with this problem. That resolution was 1360x768.

So, searching about problems with that resolution, i've found a bizarre problem regarding that resolution, some standars, and nvidia. It seems that is a bogus resolution, and there's a problem between 1360x768 and 1366x768. nVidia gpus seems to detect 1360 but no 1366. So, i went to nvidia settings (not Ubuntu control center), and setted the resolution by hand at 1366 using "advanced" option in the resolution configuration. After that, the video displays fine on my friend's machine.

Odd stuff.

share|improve this answer

Im working with Adobe Flash Player Version 11.2.202.310 and test it in fullscreen and Its seems works fine! May be He needs change and upgrade his version. Could you tellme about Flash Player embed version in Chrome? You can know about it, just right click in video in somewhere.

Take care.

share|improve this answer
    
I'm asking my friend, he'll respond when online again. But my version here (my job) is 11.9.900.117. As said, the video here plays ok, but it has some strange lag when going fullscreen that other videos don't. Guess it's gotta be some odd video spec. –  Daniel Cantarin Oct 31 '13 at 19:29

if you have trouble with youtube videos, try html5 player.

bottom of youtube page. html5 player in beta ( experiment) link.

share|improve this answer
    
Thanks for the tip. But tried the html5 test and yt just doesn't load the video with the video tag, it shows the same old flash player. Guess that video don't have html5 (firefox) compatible versions. –  Daniel Cantarin Oct 31 '13 at 19:46
    
when you activated it do not use back button. search same video again. if you use back button. test will be cancelled –  user84277 Nov 2 '13 at 13:47

Not the answer you're looking for? Browse other questions tagged or ask your own question.