Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a performance problem with my Mobility Radeon HD 54__ graphics card using default open source drivers. I'm not talking about games but non-Full HD videos. Occasionally video freezes for a short while (sound remains unaffected) and then everything is fine for another while. Sorry for my explanation but I couldn't find words to describe that behaviour. I cannot install proprietary drivers, because they seem to crash Ubuntu (13.10).

share|improve this question

1 Answer 1

AMD writes pretty crappy drivers for linux. But if you want the official drivers, and can't get them through ubuntu, go to http://support.amd.com/en-us/download , and there you can specify your video card, then they give you a download for the drivers.

share|improve this answer
    
I tried to install AMD's drivers for the second time and it resulted in the same behaviour. :/ Any other ideas? –  Luke Oct 31 '13 at 18:57
    
have you made sure that the old drivers were deleted? That might help. –  Nightshaxx Oct 31 '13 at 19:19
    
I had a fglrx driver installed, then I tried to install another, but for some reason it didn't delete the old one, and I ended up crashing my whole system. –  Nightshaxx Oct 31 '13 at 19:41
    
then why wouldn't it work in the first place? –  Luke Oct 31 '13 at 20:31
    
Sorry, what exactly do you mean? –  Nightshaxx Nov 1 '13 at 19:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.