Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Dell 1501 Inspiron laptop and I just upgraded to Ubuntu 11.04. However, now my wireless card doesn't work whereas it worked just fine in 10.10 and 10.04. Any ideas? It works fine when I hardwire.

share|improve this question
2  
Welcome to Ask Ubuntu! We need more hardware information to help you, can you look at this question and then edit your question adding the information? –  Jorge Castro Oct 17 '11 at 12:46
add comment

7 Answers

This link just got my wireless working on a inspiron 1501

http://blog.tech4him.com/2011/09/broadcom-wireless-on-ubuntu-11-04-and-11-10/

Thanks to the author

He uses two commands

sudo apt-get remove bcmwl-kernel-source
sudo apt-get install firmware-b43-installer

dunno what that does exactly I am also a newbie but I would rather be lucky than good !

share|improve this answer
    
I can confirm that just installing firmware-b43-installer alone does the trick on Ubuntu 12.04. –  ternaryOperator Apr 18 '12 at 15:27
    
Ubuntu 12.10 as well! –  Peter Cassetta Nov 30 '12 at 8:18
    
The above worked for me on Peppermint 4.0. I rebooted after and presto, wireless working. –  mungflesh Apr 14 at 22:19
add comment

open synaptic package manager, and install b43, do NOT install the driver from the Additional drivers. You'll need to start the wireless with Fn+F2 each boot, still looking for a solution for that issue. But that is the way I make my broadcom bcm4311 working in my Dell Inspiron 1501.

share|improve this answer
add comment

There is a problem some users are having with the new version 12.04 telling them it is a proprietary driver and it will refuse to load it. However, I have worked around this. Use the cutter above if you feel it will work, however if it doesn't just copy all of the files for your card into a brand new directory I'll put the commands below.

sudo mkdir /lib/firmware/b43 
sudo cp /Directory_Where_Drivers_Are /lib/firmware/b43 
sudo gedit /etc/modules

In your text editor add the line b43 at the bottom, then save the file. Reboot your system and it will recognize your card and forget the warning.

share|improve this answer
add comment

Run these commands in terminal:

sudo apt-get purge bcmwl-kernel-source broadcom-sta-common broadcom-sta-source

sudo apt-get install b43-fwcutter firmware-b43-installer

THEN UNPLUG ETHERNET AND REBOOT

share|improve this answer
add comment

it seems like you may need a non free wireless card driver. You may try the following: Connect to your ethernet , start the 'Additional drivers' program and search to find if it detects and non free drivers your wireless card. From the commnad line its

/usr/bin/jockey-gtk

Hope this helps.

share|improve this answer
add comment

I had the same problem with my Inspiron E1505 wireless card. What worked for me was I removed the driver using the Additional Drivers program and then installed the firmware-b43-installer package. Upon reboot the card worked beautifully

share|improve this answer
add comment

What worked for me, was using these commands:

sudo modprobe -rv dell-laptop
sudo modprobe -v b43

Hope this helps.

share|improve this answer
    
Welcome to AskUbuntu! You may want to add more detail about what those commands do, to convince the original poster of the quality of your answer. –  Oyibo Oct 3 '12 at 7:43
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.