Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I had to change

[General]
Enable = Socket

in /etc/bluetooth/audio.conf to get it to pair. But now that they are I don't get an output in pavucontrol.

D: [pulseaudio] bluetooth-util.c: Registering /MediaEndpoint/HFPAG on adapter /org/bluez/3855/hci0.
D: [pulseaudio] bluetooth-util.c: Registering /MediaEndpoint/HFPHS on adapter /org/bluez/3855/hci0.
D: [pulseaudio] bluetooth-util.c: Registering /MediaEndpoint/A2DPSource on adapter /org/bluez/3855/hci0.
D: [pulseaudio] bluetooth-util.c: Registering /MediaEndpoint/A2DPSink on adapter /org/bluez/3855/hci0.
E: [pulseaudio] bluetooth-util.c: org.bluez.Media.RegisterEndpoint() failed: org.bluez.Error.AlreadyExists: Already Exists
E: [pulseaudio] bluetooth-util.c: org.bluez.Media.RegisterEndpoint() failed: org.bluez.Error.AlreadyExists: Already Exists
E: [pulseaudio] bluetooth-util.c: org.bluez.Media.RegisterEndpoint() failed: org.bluez.Error.AlreadyExists: Already Exists
E: [pulseaudio] bluetooth-util.c: org.bluez.Media.RegisterEndpoint() failed: org.bluez.Error.AlreadyExists: Already Exists
D: [pulseaudio] bluetooth-util.c: dbus: property 'State' changed to value 'disconnected'
D: [pulseaudio] bluetooth-util.c: dbus: property 'State' changed to value 'disconnected'
D: [pulseaudio] bluetooth-util.c: dbus: property 'State' changed to value 'disconnected'
D: [pulseaudio] bluetooth-util.c: dbus: property 'State' changed to value 'disconnected'
D: [pulseaudio] bluetooth-util.c: dbus: property 'State' changed to value 'connected'
D: [pulseaudio] bluetooth-util.c: dbus: property 'State' changed to value 'connected'
D: [pulseaudio] bluetooth-util.c: Unknown Bluetooth minor device class 0
D: [pulseaudio] module-card-restore.c: Not restoring profile for card bluez_card.C8_84_47_15_B7_34, because already set.
I: [pulseaudio] module-card-restore.c: Restoring port latency offsets for card bluez_card.C8_84_47_15_B7_34.
I: [pulseaudio] card.c: Created 2 "bluez_card.C8_84_47_15_B7_34"
W: [pulseaudio] module-bluetooth-device.c: Profile has no transport
D: [pulseaudio] core-subscribe.c: Dropped redundant event due to change event.
I: [pulseaudio] card.c: Changed profile of card 2 "bluez_card.C8_84_47_15_B7_34" to off
I: [pulseaudio] module.c: Loaded "module-bluetooth-device" (index: #22; argument: "address=C8:84:47:15:B7:34 profile=a2dp").
I: [alsa-source] alsa-source.c: Scheduling delay of 10,06ms, you might want to investigate this to improve latency...
I: [alsa-source] ratelimit.c: 5 events suppressed
I: [alsa-source] alsa-source.c: Overrun!
I: [alsa-source] alsa-source.c: Increasing minimal latency to 2,00 ms
D: [alsa-source] alsa-source.c: latency set to 20,00ms
D: [alsa-source] alsa-source.c: hwbuf_unused=62008
D: [alsa-source] alsa-source.c: setting avail_min=442

What can I do to get it working?

Regards,

EDIT:

>>> 2 sink(s) available.
    index: 0
        name: <alsa_output.pci-0000_01_00.1.hdmi-stereo-extra1>
        driver: <module-alsa-card.c>
        [...cut...]
    index: 1
        name: <alsa_output.pci-0000_00_1b.0.analog-stereo>
        driver: <module-alsa-card.c>
        [...cut...]

EDIT2:

In pavucontrol I have "(34)Logitech Adapter". If I change the profile from "Off" to "HighFidelity Playback (A2DP)" then I get this message from pulseaudio:

W: [pulseaudio] module-bluetooth-device.c: Profile has no transport

EDIT3:

Funny. Disconnecting the device via blueman crashes pulseaudio:

E: [pulseaudio] hook-list.c: Assertion 'hook->n_firing == 0' failed at pulsecore/hook-list.c:51, function pa_hook_done(). Aborting.

EDIT4:

Upgrade to 13.10 didn't fix the problem either. There seems to be some incompatibility with bluez and pulseaudio and certain hardware...

EDIT5:

flo@io2:~$ bt-autoconnect -v

(bt-autoconnect.py:11935): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:3274:48: Expected ',' in color definition
bt-autoconnect 1.0.1 scanning: C8:84:47:15:B7:34
17193981.46: (<type 'exceptions.IndexError'>, IndexError('list index out of range',), <traceback object at 0x26a3170>)
Unable to run PulseAudio CLI
17193981.46: Found BT-device: /org/bluez/10082/hci0/dev_C8_84_47_15_B7_34
17193981.46: Connecting to DBus: /org/bluez/10082/hci0/dev_C8_84_47_15_B7_34
17193993.18: (<class 'dbus.exceptions.DBusException'>, DBusException('Connect Failed',), <traceback object at 0x26a3200>)
17193994.18: (<class 'dbus.exceptions.DBusException'>, DBusException('Connect Failed',), <traceback object at 0x26a3170>)
17193995.18: (<class 'dbus.exceptions.DBusException'>, DBusException('Connect Failed',), <traceback object at 0x26a3248>)
17193996.18: (<class 'dbus.exceptions.DBusException'>, DBusException('Connect Failed',), <traceback object at 0x26a31b8>)
17193996.2: ['C8:84:47:15:B7:34', '5', 'N', 'N', 'N']
No PulseAudio daemon running, or not running as session daemon.
share|improve this question
    
Thanks for the quick reply. Only two outputs. One pci card and hdmi. Added shortend version to the question. –  user1455622 Oct 31 '13 at 10:28
    
nope. Tried a couple of times but that's not it. –  user1455622 Oct 31 '13 at 11:02
    
OK. This is new or I just haven't seen it. In pavucontrol unter "Configuration" I got My "(34)Logitech Adapter" which was off. Changing profile to A2DP results in: W: [pulseaudio] module-bluetooth-device.c: Profile has no transport –  user1455622 Oct 31 '13 at 11:08
    
Uh - this smells of bug #1181106 --> try if removing the Enable=Socket in audio.conf makes a change for good. –  Takkat Oct 31 '13 at 11:40
    
Thanks. But if I remove this I cannot connect: "Connection failed: Stream setup failed." (blueman) I try upgrading to 13.10. –  user1455622 Oct 31 '13 at 12:11

2 Answers 2

Long time I was looking solution and finally helped me that link: http://ubuntuforums.org/showthread.php?t=2246613

Ubuntu 14.04 Audio sink problem to Logitech Wireless Adapter

Hello, jcmoriaud. I had this problem recently as I bought a bluetooth speaker and attempted to connect to it with my laptop. It kept giving me "Connection Failed: Stream setup failed". I eventually figured out how to make it work like this. You need to have pulseaudio installed, which you can check for in Synaptic Package Manager by typing pulseaudio into the search bar. You can install it from there if it isn't already installed. Next, you need to install pavucontrol, either in Synaptic Package Manager, or by running this in the terminal. Code: sudo apt-get install pavucontrol This is the unfortunate part. Every time you boot, you need to run this command in the terminal before any bluetooth devices attempt to connect. Code: pactl load-module module-bluetooth-discover You can now go into the bluetooth manager and tell it to connect to the device as an A2DP audio sink. Now, finally, if you go into the PulseAudio Volume Control, on the Playback tab, you can choose the option to send audio through the bluetooth device. Good luck with this."

I using this with Blueman (GTK+ Bluetooth Manager)

share|improve this answer
    
pulseaudio is installed by default, pavucontrol is unrelated, and loading module-bluetooth-discover has already been suggested in another answer. And please stop shouting! People can read your text even when it's not bold. –  David Foerster Dec 17 at 12:10
    
Hey. Wellcome. That worked. Thanks a lot! –  user1455622 Dec 18 at 11:44

I have been having similar problems. I managed to get it working by removing Socket from the enable line in /etc/bluetooth/audio.conf referenced at the beginning of the question. Next, from the command line run:

pactl load-module module-bluetooth-discover

Then you should be able to connect properly to the bluetooth audio device.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.