Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm currently (for some days now) having the problem, that my Ubuntu clock runs to fast. and by to fast I mean like: last time I adjusted it was at 4 PM, now (10:25 PM) it shows 10:57 PM ! Any ideas how to fix that?

Could it have something to do with handbrake? (I'm currently ripping my DVD collection, so handbrake is always running).

My System:

Ubuntu 10.4, all updates, handbrake from getdeb (0.9.4 I think), Intel Core2Quad, 4 GB Ram, NVidia GTX 260 (195.36.24 according to nvidia-settings)

thx for any help

Edit:

share|improve this question
    
Please post the output of the 'dmesg' command and the content of the /proc/interrupts file and also the /proc/cmdline file –  ithkuil Sep 5 '10 at 21:31

4 Answers 4

up vote 3 down vote accepted

Maybe your CMOS battery is getting empty (the battery on the motherboard itself).

You can hit F1 (or DEL according to you motherboard) at the first seconds during pc starup to enter BIOS.

in the BIOS you can check the hardware clock.

Just let the computer run and check if the time stays correct (during this time you can't use your computer)

If the hardware clock is not running correctly, you can replace the battery. http://www.computerhope.com/issues/ch000239.htm

share|improve this answer
    
I tried the trick with the bios and I think it was the same problem there. So I replaced the battery and now everything seams to work fine. Unfortunately my computer didn't want to boot anymore after reconfiguring the bios (grub: unknown filesystem) so I installed Ubuntu 10.10 beta now. But anyway, if the clock ticks correctly until this evening I will mark this answer as the correct one. –  sBlatt Sep 6 '10 at 12:11

While I'm not sure what is causing your system clock to drift so badly, you can install ntpd to keep your clock in hand - it continuously adjusts the system clock based on the calculated drift.

sudo apt-get install ntp

By default it syncs to ntp.ubuntu.com but you can edit /etc/ntp.conf if you want to change the NTP server. For more details see the NTP page in the server guide.

share|improve this answer
    
clock drifting can be a major problem and cause for program instability (even if you sync with ntp) because you can't sync every second with the internet. –  aatdark Sep 6 '10 at 11:22
    
No, but you can calculate the drift and then compensate for it, which ntpd does (smoothly, I might add). –  jbowtie Sep 8 '10 at 3:11

If I recall an article I read once on lwn.net

Once the computer is booted it keeps track of time by the clock frequency of the system as this is more accurate than the quartz in the cmos and saves an expensive and (relatively) slow BIOS call.

There was a problem with virtual machines having their CPU time sliced that caused the problem.

This person has a good breakdown of how to edit the grub boot options: http://ubuntuforums.org/showthread.php?t=956263

Which basically says to edit the /boot/grub/menu.lst and add clock=tsc to the boot options

share|improve this answer
1  
+1. However the steps are for grub-legacy. Ubuntu 10.04 uses grub2 which would not have any /boot/grub/menu.lst but the config information is stored in /boot/grub/grub.cfg. Except for the change of filename all other details in the linked post look ok. However grub.cfg gets regenerated each time a new kernel is added (via e.g., software updates), so the permanent fix would be to edit the grub templates. See grub 2 guide at ubuntuforums.org/showthread.php?t=1195275 or official manual at gnu.org/software/grub/manual –  koushik Sep 6 '10 at 11:32

Just a guess, try un-installing VirtualBox.

share|improve this answer
    
I don't actually see a difference between this answer and others that suggest trying out something (like installing ntpd or checking the bios). Well, apart that it's so short that it seems more fit for a comment. But, although upvotable, a comment cannot be selected as correct answer, so in the case this was indeed the solution for his problem (as it solved a similar situation for me if I remember correctly) it made sense IMHO to write it as an answer. –  ithkuil Aug 21 '12 at 17:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.