Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently installed a clean version of Windows 8.1 Professional on my Lenovo Y500 (with Samsung 256GB 840 Pro SSD).

I have Windows all set up and running normally.

I am trying to dual boot Windows 8.1 and Ubuntu 13.10, but the installation procedure don't allow me to either "Install alongside..." or shows my SSD partitions correctly when I chose the "Something Else" option.

I have created a 25GB partition of free space in the Windows disk manager, but on the installation screen on Ubuntu, it shows the whole drive as a free space.

I have tried installing with a burned .ISO disk and a bootable USB, the results are the same for both.

Windows Disk Management screen: http://imageshack.us/a/img855/9504/59zu.jpg
The Ubuntu installation screen: http://imageshack.us/a/img62/2712/9g6i.jpg

I've ran into this problem before when trying to dual boot Ubuntu and Windows 7 Professional a month ago. But I gave up and never resolved the issue.

--EDIT--
I tried what Eero Aaltonen suggested, and this is my result:

ubuntu@ubuntu:~$ sudo parted /dev/sda print
Warning: /dev/sda contains GPT signatures, indicating that it has a GPT table. However, it does not have a valid fake msdos partition table, as it should. Perhaps it was corrupted -- possibly by a program that doesn't understand GPT partition tables. Or perhaps you deleted the GPT table, and are now using an msdos partition table. Is this a GPT partition table?
Yes/No? yes
Model: ATA Samsung SSD 840 (scsi) Disk /dev/sda: 256GB Sector size (logical/physical): 512B/512B Partition Table: gpt

Number Start End Size File system Name Flags

ubuntu@ubuntu:~$

share|improve this question
    
Btw, you should add a comment if you make some changes. Otherwise I won't get any notification that something has happened :P –  Eero Aaltonen Nov 12 '13 at 11:16

1 Answer 1

Well, it looks like the Ubuntu installer is unable to detect / read the partition table used by windows.

Boot with LiveCD and check what

sudo parted /dev/sda print

gives you (original post).

I have an MBR partition table, so for me it states "Partition Table: msdos".

UPDATE: Hmm, your problem seems very similar to this question.
According to "Lenovo Y500 User Guide", the default boot mode on your laptop is UEFI. However, check which boot mode you are using before applying any fixes.

Also linking this question since it contains a great deal of info about dual booting.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.