Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I had to reinstall Ubuntu and always used Guake Terminal and it was always starting when the desktop appeared and I only pressed F12 and it did everything I had to.

But now it doesn't start automatically. I was looking for an answer but nothing worked. Has anybody ideas how to solve it ? It would be really nice to use it as earlier ;)

share|improve this question
This worked for me askubuntu.com/questions/136559/… –  jblaya Dec 23 '13 at 14:44

4 Answers 4

have you tried adding it to the startup applications (search "startup applications")

If you have, try adding a .desktop file to /etc/xdg/autostart/

You can do this with the following command

sudo ln -s /usr/share/applications/guake.desktop /etc/xdg/autostart/

This is just an example, I don't know what the guake .desktop file is named but you can easily find out by having a look in the map: /usr/share/applications/

If by chance that doesn't work as well then there is one other solution you could try adding the following command to the startup applications

bash -c "sleep 10 && guake"

if it doesn't work try varying the sleep time because it depends on your system's speed but usually 10 seconds will work just fine

I hope this helps

share|improve this answer
I tried it with the Startup Applications and it didn't work earlier, the same now. But adding the desktop file solved the problem ! ;) Thanks very much ! –  Karim Oct 30 '13 at 21:47
Goto System -> Preferences -> Startup Applications.


Dash -> Type: Startup Startup Applications

The Startup Application Preferences window opens. Then, click in Add, give a Name for the Application in the Name field ("Guake" it's enough), and then type “guake” without quotes in the command field and click Add. Then close the Startup Application Preferences window and restat the machine, now Guake should start automatically on login.


share|improve this answer

Use this:

sudo cp /usr/share/applications/guake.desktop /etc/xdg/autostart/
share|improve this answer

This helps for me:

Guake Doesn't Start When Session Starts

In Guake's preferences just uncheck Enable notifications on startup, and add the full path (e.g. `/usr/bin/guake) to startup applications.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.