Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I upgraded the other day from Ubuntu 13.04 to 13.10 on my ZaReason laptop, and the WiFi doesn't reconnect after suspend.

In 13.04, pressing Fn+F2 turned network connections back on after suspend. The 'soft' wireless hardware switch.

But in 13.10, that doesn't work, and trying to enable networking in the networking menu doesn't work either. So I have to restart every time.

Any suggestions to make it work?

share|improve this question

marked as duplicate by guntbert, karel, Braiam, Aditya, qbi Oct 31 '13 at 23:25

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Have you tried turning wireless off before suspending? –  Novine Oct 30 '13 at 19:36
    
@guntbert err... that got closed because it's a bug. –  Braiam Oct 31 '13 at 1:47
    
@braiam indeed - this is about the same bug, but pointing people to the question with more info is still good, don't you think? –  guntbert Oct 31 '13 at 17:39
    
Also see askubuntu.com/questions/365441/… –  belacqua May 25 at 3:06

3 Answers 3

The answer above solves the problem in a one off fashion, but these steps solved the longterm issue for me:

sudo touch /etc/pm/sleep.d/wakenet.sh

sudo chmod +x /etc/pm/sleep.d/wakenet.sh

sudo gedit /etc/pm/sleep.d/wakenet.sh

Insert the following lines:

#!/bin/bash
case "$1" in
thaw|resume)
nmcli nm sleep false
;;
*)
;;
esac
exit $?

And then save.

Solution found here

share|improve this answer

Workaround:

Try restarting the network manager to start wifi again:

sudo service network-manager restart

Update:

http://askubuntu.com/a/362148/175489

Much better workaround:

sudo nmcli nm sleep false
share|improve this answer

Please do:

sudo gedit /etc/pm/config.d/config

A new empty file will open. Add one line:

SUSPEND_MODULES="rtl8192ce" 

Of course, substitute your actual driver in place of rtl8192ce. Proofread, save and close gedit. Reboot

If you do not know the name of your wireless driver run this command:

lspci -nnk | grep -iA2 net

it will tell you the device name for wireless and ethernet along with the driver being used for each.

Edit: This second method will most likely work if the first one does not:

sudo touch /etc/pm/sleep.d/wakenet.sh

sudo chmod +x /etc/pm/sleep.d/wakenet.sh

sudo gedit /etc/pm/sleep.d/wakenet.sh

Insert the following lines:

#!/bin/bash
case "$1" in
thaw|resume)
nmcli nm sleep false
;;
*)
;;
esac
exit $?
Save

This answer was found on the forum

share|improve this answer
    
It works, but I still have to press Fn+F2 after I enable networking for the WiFi to come on. That's fine though, I've had to do that with 13.04 as well. –  Matthew Oct 31 '13 at 4:36

Not the answer you're looking for? Browse other questions tagged or ask your own question.