Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After a short stint with VMWare Player, Virtualbox and Winconn*, I'm now apparently stuck with a broken Ubuntu installation.

Even after uninstalling VMware Player and Winconn (I won't uninstall Virtualbox, since that's my main means of virtualization which I've been using for much of my career), I'm unable to suspend, shutdown or reboot.

Whenever I attempt to shut down or reboot the system, it will become stuck at the splash screen (which is an oddity in itself, since I already disabled the splash screen where-ever I could. Including the GRUB config). Whenever I attempt to suspend (either by terminal, Ubuntu menu entry or by shutting my laptop lid), the screen will turn black while the rest of the system is still running in full force.

Anyone out there who might know a solution that doesn't come down to "re-install everything"?

What I've already tried:

  • Uninstalled everything I installed yesterday (including the kernel modules VMWare kept asking for, excluding Virtualbox and Virtualbox Guest Additions).

  • Re-installed and re-initialized AMD fglrx drivers.

  • Upgraded the kernel to 3.12RC7 (wouldn't work, since it's now asking for a valid GPU driver and won't let me log in with either a terminal session or default graphics)

  • added GRUB_CMDLINE_LINUX_DEFAULT="acpi=noirq quiet splash" to /etc/default/grub, as was recommended in an older thread for 12.04.

  • force updated grub for half a dozen times.

  • force downed the network manager service before shutting down the system.

  • edited /etc/default/speech-dispatcher (R

  • managed to get into verbose mode just once, only to be greeted by an pci_msi segfault (GPU driver, possibly?)

My setup, according to "uname":

3.8.0-32-generic #47-Ubuntu SMP Tue Oct 1 22:35:23 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

I'm really at a loss here. I hope someone will be able to help me save my precious setup. :(

EDIT: Forgot to mention. My specs are as follows:

  • Lenovo Thinkpad E535
  • CPU: AMD A8-5800 @ stock
  • GPU: AMD Radeon HD 7640G
  • fglrx: Catalyst 12.9 (tried the most recent beta but it refused to boot into Unity with my APU, so the choice was to either downgrade -- what is what I did -- or stick with the power hungry 7670m)
  • RAM: 4GB

*I actually wanted to find the best way to seamlessly run Windows 7 applications from within my Ubuntu setup.

share|improve this question
    
I'm assuming you wanted to run the windows 7 apps without WINE or CrossOver. Did you try the --nomodeset option before launching ubuntu, it's a longshot but it fixed an issue I was having. Other than that Im at a loss. –  Cole Busby Oct 30 '13 at 19:48
    
You should be able to shutdown by using sudo shutdown -h now, or reboot using sudo shutdown -r now. Also, I think the splash is run by plymouth. I think you can disable it, but you could just change the theme (you can list the ones available by running sudo plymouth-set-default-theme --list) to details (run sudo plymouth-set-default-theme details) which will just display the details of boot-up or shutdown instead of the default one. –  Wilf Oct 30 '13 at 20:26
    
One more point, suspending never really is really a good idea, particularly if the computer is not working very well. It suspends by storing the machine state inside the RAM, which is volatile memory. Also, if you want to run Windows 7 applications on your computer, you should be able to run them under Wine, and you can find how well they are likely to run here. –  Wilf Oct 30 '13 at 20:29
    
Hi there. Thanks. I'll try --nomodeset in a few. I just re-installed fglrx for what must be the 10th time in a row and actually managed to reboot my system with "sudo reboot -f". That's the only command that successfully rebooted my system in quite a few hours. –  user2534826 Oct 30 '13 at 20:57
    
@wilf I usually just suspend over night or when I'm on the road. What you're saying about it is, of course, true but I don't ever keep anything important open anyways. –  user2534826 Oct 30 '13 at 20:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.