Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have this proprietary software that access some hardware using USB. Over a year ago I tried to install it on a Ubuntu OS using Wine (the program is written for Windows). The UI seemed to work just fine but it had no access to the USB port. Back then I had to license a Windows copy in order to get the job done.

Now, that Windows version we where using is deprecated and it is not longer available and available versions cost trice as much. So it is time to give Linux another try.

How can I ensure that the USB is available for a Wine application? Neither the application nor the hardware install any driver, the app just pool all available USB drivers and make a handshake if it recognizes that the hardware is present.

I want to minimize the test cases before abandoning Linux one more time.


Update

I've just tried again (with the hope an upgrade was made from last year), and it is not working. The proprietary windows app is not finding the hardware.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.