Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm having a very hard time getting webex to work under Saucy. Up until now I've been able to just install a java plugin, install ia32-libs, and I was good to go. With Saucy ia32-libs is gone and it's up to us to figure out which 32-bit libraries we need to install.

So the question is, how do I install WebEx on 64bit Saucy without ia32-libs?

share|improve this question
    
sudo update-alternatives --set "/usr/local/java/jre1.7.0_51/lib/i386/libnpjp2.so" "mozilla-javaplugin.so" does'n't work, but I think it should be the other way around sudo update-alternatives --set "mozilla-javaplugin.so" "/usr/local/java/jre1.7.0_51/lib/i386/libnpjp2.so, if I understand the update-alternatives syntax right. –  flenst111 Mar 31 at 7:52
    
Did it like cdupont, but if I start firefox I get this error-messages ./firefox XPCOMGlueLoad error for file /home/paulsen/firefox32/firefox/libxul.so: libXt.so.6: cannot open shared object file: No such file or directory Couldn't load XPCOM. –  flenst111 Mar 31 at 8:00

5 Answers 5

From this post, here is a step-by-step method that might work:

  1. Install JDK.
  2. Configure Java plugin for browser (no need for a 32-bit JDK or Firefox).
  3. Start a WebEx to create .so files inside $HOME/.webex/????/.
  4. Check for unresolved .so dependencies:
    ldd $HOME/.webex/????/*.so > $HOME/check.txt
    
  5. Search for missing libraries:
    grep "not found" $HOME/check.txt | sort | uniq
  6. Review the libraries; for example:
    libasound.so.2 => not found
    libjawt.so => not found
    libXmu.so.6 => not found
    libXtst.so.6 => not found
    libXv.so.1 => not found
    
  7. Find the corresponding packages:
    sudo apt-get install apt-file
    sudo apt-file update
    
  8. Locate that package that contains the missing libraries:
    apt-file search libXmu.so.6
    apt-file search libjawt.so
    
  9. Install the missing libraries, for example:
    sudo apt-get install -y libxmu6:i386
    sudo apt-get install -y libasound2:i386
    sudo apt-get install -y libxv1:i386
    sudo apt-get install -y libxtst6:i386
    sudo apt-get install -y libgcj12-awt:i386
    
share|improve this answer
    
Can you confirm that you get a lot of these errors in your console: java.lang.UnsatisfiedLinkError: .../.webex/1324/libdbr.so: wrong ELF class: ELFCLASS32? –  Aaron Digulla Apr 7 at 8:31

ldd was not working for me and would return "not a dynamic executable" for the *.so files

~/.webex/1424$ ldd *.so
atascli.so:
    not a dynamic executable
atgzip.so:
    not a dynamic executable
atjpeg.so:
    not a dynamic executable
atpng.so:
    not a dynamic executable

I had to install these 3 packages to get it to run (replacements for ia32-libs)

lib32z1 
lib32ncurses5 
lib32bz2-1.0

After that this command helped me find the packages I needed (can take a while)

$ for x in `ldd *.so | grep "not found" | sort -u | awk '{print $1}'` ; do apt-file search $x >> packages.txt ; done
share|improve this answer

Here are the complete instructions for my future self and those interested. The solution is to install firefox 32 bits with Oracle Java 32 bits.

First get firefox 32 bits:

wget http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/latest/linux-i686/en-US/firefox-27.0.1.tar.bz2
bunzip2 firefox-27.0.1.tar.bz2
tar -xvf firefox-27.0.1.tar

Then get Oracle java 32 bits (replace download with latest version):

wget --no-cookies --header "Cookie: gpw_e24=http%3A%2F%2Fwww.oracle.com" "http://download.oracle.com/otn-pub/java/jdk/7u51-b13/jre-7u51-linux-i586.tar.gz"
tar -xzvf jre-7u51-linux-i586.tar.gz
mkdir /usr/local/java
sudo mv jre1.7.0_51 /usr/local/java

Create and activate the alternative for the java plugin into firefox:

sudo update-alternatives --install "/usr/lib/mozilla/plugins/libjavaplugin.so" "mozilla-javaplugin.so" "/usr/local/java/jre1.7.0_51/lib/i386/libnpjp2.so" 1
sudo update-alternatives --set "mozilla-javaplugin.so" "/usr/local/java/jre1.7.0_51/lib/i386/libnpjp2.so" 

Shut down all instances of Firefox if already running, and start 32 bits firefox:

cd ~/firefox
./firefox

To check the version of java, type about:plugins in the address bar. It should display:

Java(TM) Plug-in 10.51.2
File: libnpjp2.so
Path: /usr/local/java/jre1.7.0_51/lib/i386/libnpjp2.so
Version: 10.51.2
State: Enabled
Next Generation Java Plug-in 10.51.2 for Mozilla browsers

Note that when you are done with Webex, you can change back your version of the java plugin to the 64 bit version (if it was installed) by typing:

sudo update-alternatives --config "mozilla-javaplugin.so"

And selecting the correct entry.

Additionally, it is necessary to install missing webex libraries as described in Russ Lowenthal's answer:

cd ~/.webex
ldd *.so | grep "not found"
#get the package containing the missing libraries (example libXtst.so.6):
dpkg -S libXtst.so.6
#install the corresponding package (appending i386 for the 32bits version)
sudo apt-get install libxtst6:i386

Tested also on a fresh install of Ubuntu 14.04 Trusty Tahr, it works. Let me know if you have problems.

share|improve this answer
    
how functional is Webex under 32-bit FF? can you share your desktop? –  Kendor Mar 31 at 17:18
    
Yes you can share your desktop, eveything works fine. The sound is perfect, the only problem is that from time to time the java VM and pulseaudio take 100% of their CPU and then the sound gets inaudible. I didn't found a definitive solution yet, but usually closing some applications, restarting the sound or stoping the screen share solves the problem. –  cdupont Apr 1 at 17:49
    
Gave this a whirl, but got stuck on the alternative plugin setup... the first command works, but the second doesn't: me@X230:~$ sudo update-alternatives --set "/usr/local/java/jre1.7.0_51/lib/i386/libnpjp2.so" "mozilla-javaplugin.so" update-alternatives: error: alternative name (/usr/local/java/jre1.7.0_51/lib/i386/libnpjp2.so) must not contain '/' and spaces –  Kendor Apr 1 at 21:54
    
+1 Note: If you don't want to pollute /etc/alternatives (which isn't 32/64bit aware), you can put the plugin into a folder and set MOZ_PLUGIN_PATH. See askubuntu.com/questions/383960/… –  Aaron Digulla Apr 7 at 11:41
    
Kendor: corrected –  cdupont May 23 at 11:41

The previous answer will do this as well, but I am a bit lazy, so I rebuilt the ia32-libs-multiarch package for Saucy and it works for me. All I did was change two dependencies for libglphoto-2 to the current version and repackage the raring package for multiarch.

It is available here, at my long-forgotten Word Press site. Don't write as a regular blogger that much primarily because work keeps me busy in Support. Besides, OrangeCrate is long dead because of the same reason. Work keeps me busy, and I credit learning Linux for that.

Anyway, have a nice day. Don't worry, be happy.

share|improve this answer

If anyone gets here but doesn't find the .webex folder check the following:

Cannot start Webex session. Java permission issue?

share|improve this answer

protected by Community Mar 31 at 8:43

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.