Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to get Juju working on Windows 8 but I am running in to some errors when trying to get juju to see my ssh keys:

C:\Users\username> juju bootstrap
error: error parsing environment "azure":
    read C:\Users\user\SkyDrive\Documents\Azure\ssh\: The handle is invalid.

I've added a public key I generated with putty to the directory above called azure

My environments.yaml file has this in it:

authorized-keys-path: C:\Users\user\SkyDrive\Documents\Azure\ssh\

Any ideas?

share|improve this question
    
Do you get this error if you quote the path? I think the : in C:\ is throwing this off. Try authorized-keys-path: "C:\Users\user\SkyDrive\Documents\Azure\ssh" –  Marco Ceppi Oct 30 '13 at 1:35
    
I'm having trouble finding documentation that points to authorized-keys-path -- is it supposed to be a directory or a file? (And what's it do? :) –  sarnold Oct 30 '13 at 1:39
    
Yes that seemed to work there thanks! But now I get another error with: error: cannot parse; C:\Users\user\AppData\Roaming\Juju|enviornments.yaml\YAML error : line 126: did not find expected hexadecimal number - it seems that it does not like my subscritpion id that I created with a new azure account –  Claude Tyler McAdams Oct 30 '13 at 2:06
    
@ClaudeTylerMcAdams Ask Ubuntu works best when you ask a question. If you have a different issue consider opening a new question with that. However, it's likely also a quoting issue. Please try quoting the value for your subscription id like you did for authorized-keys-path –  Marco Ceppi Oct 30 '13 at 3:47
1  
@sarnold it's a global option that probably not documented anywhere. There's authorized-keys-path and authorized-keys. I'd be happy to answer that in another question :) –  Marco Ceppi Oct 30 '13 at 3:48
add comment

1 Answer

YAML can be quite picky about formatting, whenever you have something other than alpha numberics make sure to apply quotes.

authorized-keys-path: "C:\Users\user\SkyDrive\Documents\Azure\ssh\"

Should resolve the issue.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.