Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Ubuntu 13.10 on my laptop. I downloaded DraftSight and tried to install it via terminal using this commands I found online:

sudo apt-get install ia32-libs libdirectfb-extra libxcb-render-util0
sudo dpkg --force-all -i ~/Downloads/draftSight.deb
sudo apt-get -f 

It said some package is missing and offered to replace it with other packages which I did. I found icon but when I try to run Draft this message pops: "Failed to load modules. The application will close.Please reinstall the application." When I try to uninstall it, it says it can't be done because it's not installed.

I'm not to familiar with Ubuntu, I have just started using it. Can someone please tell me how to fix this, I need this programme for my lectures and I don't want to give up using Ubuntu.

share|improve this question
    
Please find help in this link: ubuntuhandbook.org/index.php/2013/11/… Works for me. Hopefully for everybody else. –  Toni Ridwan Mar 12 at 11:49

3 Answers 3

Try gdebi, it will download the missing dependencies:

sudo apt-get install gdebi

sudo gdebi ~/Downloads/draftSight.deb
share|improve this answer
    
Thanks for the tip but the same message pops when I try to run it: "Failed to load modules. The application will close. Please reinstall the application." Is there anything else I can do? –  Luby Lou Oct 31 '13 at 14:14

I had this problem too. This seems to solve it:

sudo apt-get install libcanberra-gtk-module:i386 libcanberra-gtk0:i386
share|improve this answer
    
libcanberra-gtk-module:i386 and libcanberra-gtk0:i386 are not in the Ubuntu repositories. Did these two files come from a PPA? Please add information to your answer about the software sources of libcanberra-gtk-module:i386 and libcanberra-gtk0:i386. –  karel Dec 23 '13 at 20:41

You have to alter the .deb file

#!/bin/sh

## Fix a DraftSight Debian package to make it installable on a 64bit machine.

## Last known realease is http://dl-ak.solidworks.com/nonsecure/draftsight/V1R4.0/draftSight.deb

ORIGINAL=draftSight.deb
PACKAGE=fixed-$ORIGINAL

if ! test -f $ORIGINAL
then
echo "$ORIGINAL file does not exist."
PACKAGE=$(zenity –file-selection –filename=draftSight.deb –file-filter=deb)
fi

echo "Copying $ORIGINAL into $PACKAGE"
cp $ORIGINAL $PACKAGE || exit 5;

echo "Extracting control.tar.gz"
ar x $PACKAGE control.tar.gz || exit 5;

echo "Unpacking control.tar.gz into control directory"
mkdir --parents control || exit 5;
tar -zxf control.tar.gz --directory control || exit 5;
mv control.tar.gz control.tar.gz.orig

echo "Removing wrong dependency (xdg-utils)"
if sed -in-place -e "s/ xdg-utils,//" control/control
then
  echo "Repacking contents of ‘control’ directory into control.tar.gz"
  (cd control; tar --create --file ../control.tar *) || exit 5;
  gzip --best --no-name control.tar
  echo "Storing patched control.tar.gz back into $PACKAGE";
  ar r $PACKAGE control.tar.gz || exit 5;
  echo "Draftsight original package $ORIGINAL patched into $PACKAGE"
fi
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.