Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've recently switched to Linux, having a good knowledge of how it works before switching, since I've had experience working with Ubuntu-based servers for several months. I've been trying to install a LEGO CAD program that I have found based on an open source library. Information on that is here. The program I'm looking at is called Konstruktor, and for the most part it should be working. One dependency however does not seem to be able to install. The missing dependency is "kdelibs5", which I know what it is and what it's for, but can't get it to install. When trying to install, I get this error:

george@GEORGE-PC:~$ sudo apt-get install kdelibs5
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package kdelibs5 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'kdelibs5' has no installation candidate

When trying to install the proper package of Konstruktor for my system, I get this error:

george@GEORGE-PC:~$ sudo dpkg -i '/home/george/Downloads/konstruktor_0.9-beta1-2_amd64.deb'
Selecting previously unselected package konstruktor.
(Reading database ... 224684 files and directories currently installed.)
Unpacking konstruktor (from .../konstruktor_0.9-beta1-2_amd64.deb) ...
dpkg: dependency problems prevent configuration of konstruktor:
konstruktor depends on kdelibs5 (>= 4:4.4.5); however:
Package kdelibs5 is not installed.

dpkg: error processing konstruktor (--install):
dependency problems - leaving unconfigured
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Processing triggers for mime-support ...
Processing triggers for hicolor-icon-theme ...
Processing triggers for shared-mime-info ...
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
Unknown media type in type 'uri/mms'
Unknown media type in type 'uri/mmst'
Unknown media type in type 'uri/mmsu'
Unknown media type in type 'uri/pnm'
Unknown media type in type 'uri/rtspt'
Unknown media type in type 'uri/rtspu'
Errors were encountered while processing:
konstruktor

I have tried updating and adding apt repositories for KDE packages, but I continuously get the same error. I tried the package "kdelibs5-dev", which installed fine, but "kdelibs5" won't, and Konstruktor still won't install. I am on Ubuntu 13.10 with GNOME shell on amd64 architecture. Any help would be much appreciated.

(originally posted my issue here)

Thanks ahead of time.

share|improve this question

1 Answer 1

Have you tried installing a kdelibs5 deb file such as this one directly?

share|improve this answer
    
After installing the amd64 deb for kdelibs5, I got errors regarding dependencies, where it appears that the errors were saying that the versions of the listed dependencies were too new of a version. For example: kdelibs5 depends on kdelibs5-plugins (= 4:4.8.5-0ubuntu0.2); however: Version of kdelibs5-plugins on system is 4:4.11.2-0ubuntu2. That's just one of the listed dependency errors, but they're all pretty similar. Would it be reasonable to downgrade versions? –  George Barnick Oct 29 '13 at 22:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.