Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In my ubuntu 13.10 desktop, I downloaded LAMP, i can see "it works!" after typing http://localhost. Now I want my sites available to any people if they type my public ip address in any computer. I did some research, but still not work. I am using time warner cable at home wirelessly,after i know my internal ip address is 192.168.2.8, i add these lines to /etc/network/interfaces:

auto eth0
iface eth0 inet static
address 192.168.2.100
netmask 255.255.255.0
gateway 192.168.2.1
broadcast 192.168.2.255
dns-nameservers 192.168.2.1

and from portforward.com, i know i should change my router setting, so i go to 192.168.2.1 which is my router address, then i moved to "vitrul servers" menu, add port 80 and 443( this is for apache this software).

My problem comes from the first part: after I changed /etc/network/interfaes, i can't connect to internet!! why? how can i fix this? My second question is that:suppose i fix this, then that's all?can my public ip address be access from then? or did i miss some important steps?

share|improve this question
    
Why you had to change /etc/network/interfaces? Just telling your router to redirect requests from port 80/443 to your machine should be enough. –  Salem Oct 29 '13 at 22:01
    
you are right, thank you so much, i was so silly. But that change is because i want to change my dynamic ip to static(even though i never found my ip address changed),which made me lose access to internet.I still don't know why it happened. –  user2869734 Oct 30 '13 at 4:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.