Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Hey I got this problem on my fresh xubuntu 13.10 install

I have a Data device /dev/sda5 which I like to auto-mount it on startup, I added it to the /etc/fstab file

UUID=261ff894-502a-4b5b-8bc7-b53a8ab8e325 /home/linuxer/DATA/   ext4    rw      0       0

The problem is that when the I login and access the folder it's empty!
Although when I echo the command

mount

it says that /dev/sda5 is mounted at /home/linuxer/DATA/ !
So I have to unmount it, and it displays:

umount: /home/linuxer/DATA: not mounted

but on remount, it displays well!

I've got another line in my /etc/fstab

UUID=208A8DE78A8DBA34   /media/win7onsada3      ntfs    rw      0       0

and this one works just fine.. It auto-mounts on startup


I have my system set -up with LVM support activated.
Any help would be appreciated!


output of blkid

/dev/sda1: LABEL="Recovery" UUID="CC0E4D840E4D6892" TYPE="ntfs" 
/dev/sda2: LABEL="System Reserved" UUID="F43C763F3C75FD44" TYPE="ntfs" 
/dev/sda3: UUID="208A8DE78A8DBA34" TYPE="ntfs" 
/dev/sda5: LABEL="Data" UUID="261ff894-502a-4b5b-8bc7-b53a8ab8e325" TYPE="ext4" 
/dev/sda6: UUID="42de199a-60ae-48f4-93e0-1d9cb79b93a1" TYPE="ext2" 
/dev/sda7: UUID="gfZ1YH-J0nl-b3l2-uXsA-7Gib-HXWf-6LLX2w" TYPE="LVM2_member" 
/dev/mapper/Distros-ROOTDIR: UUID="ddce62f6-1acb-4878-a079-cc50bb7bc18d" TYPE="ext4" 
/dev/mapper/Distros-HOME: UUID="96bda727-1db2-4513-be08-a79e09fe350e" TYPE="ext4" 
/dev/mapper/cryptswap1: UUID="f6f1556b-d3d2-480e-b3a1-07a79335fa4e" TYPE="swap" 

output of cat /etc/fstab

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
/dev/mapper/Distros-ROOTDIR /               ext4    errors=remount-ro 0       1
# /boot was on /dev/sda6 during installation
UUID=42de199a-60ae-48f4-93e0-1d9cb79b93a1 /boot           ext2    defaults        0       2
/dev/mapper/Distros-HOME /home           ext4    defaults        0       2
/dev/mapper/Distros-SWAP none            swap    sw              0       0
/dev/mapper/cryptswap1 none swap sw 0 0

#/home/linuxer/Data
UUID=261ff894-502a-4b5b-8bc7-b53a8ab8e325 /home/linuxer/Data/   ext4    defaults,user   0   2
# windows
UUID=208A8DE78A8DBA34   /media/win7onsada3  ntfs    rw  0   0

output of lsblk

NAME                       MAJ:MIN RM   SIZE RO TYPE  MOUNTPOINT
sda                          8:0    0 698.7G  0 disk  
├─sda1                       8:1    0  14.1G  0 part  
├─sda2                       8:2    0   100M  0 part  
├─sda3                       8:3    0   200G  0 part  /media/win7onsada3
├─sda4                       8:4    0     1K  0 part  
├─sda5                       8:5    0   300G  0 part  
├─sda6                       8:6    0   250M  0 part  /boot
└─sda7                       8:7    0 184.2G  0 part  
  ├─Distros-SWAP (dm-0)    252:0    0     5G  0 lvm   
  │ └─cryptswap1 (dm-3)    252:3    0     5G  0 crypt [SWAP]
  ├─Distros-ROOTDIR (dm-1) 252:1    0    10G  0 lvm   /
  └─Distros-HOME (dm-2)    252:2    0    95G  0 lvm   /home
sr0                         11:0    1  1024M  0 rom   
share|improve this question
1  
edit your question and post the output of sudo blkid and cat /etc/fstab. –  Saurav Kumar Oct 29 '13 at 18:26
    
Done! output added. –  Ayman Oct 29 '13 at 18:36
    
I'm confused with your Dat and Data, dat and Data.. :P Also post the output of sudo lsblk –  Saurav Kumar Oct 29 '13 at 18:49
    
Hope it's less confusing now ;) Done! output added. –  Ayman Oct 29 '13 at 18:53
1  
Have you tried using defaults instead of rw in your /etc/fstab? –  edwin Oct 29 '13 at 20:07

3 Answers 3

So the last command shows that your /dev/sda5 partition is not mounted

I don't know what steps did you follow. Let us try to mount it again. So please follow these steps.

  1. First unmount all the partitions by:

    sudo umount -a
    
  2. Then make a directory Data under /home/linuxer. If already such directory then first remove it,then create:

    sudo mkdir /home/linuxer/Data
    
  3. Give the permission 777 to the directory Data. You can change the permission according to your need:

    sudo chmod -R 777 /home/linuxer/Data
    
  4. Now edit the file /etc/fstab. So open in any text editor with root permission and do the changes.

    sudo nano /etc/fstab
    

    Then remove the line:

    UUID=261ff894-502a-4b5b-8bc7-b53a8ab8e325 /home/linuxer/DATA/   ext4    rw  0   0
    

    and add this:

    UUID=261ff894-502a-4b5b-8bc7-b53a8ab8e325 /home/linuxer/Data    ext4 errors=remount-ro 0       1
    

    Press Ctrl+X to close, when prompt to save press Y.

  5. Now mount all the partitions using this command:

    sudo mount -a
    

Reply if something goes wrong. Your partition should mount automatically when you reboot your system.

share|improve this answer
    
Nope... Same problem! I can remount but it doesn't go automaticly on reboot! –  Ayman Oct 29 '13 at 19:41
    
That is why I tested it first before giving the answer. It is working fine for me. I don't know what wrong in your case. Ok last try to change the mount point from /home/linuxer/Data to /media/Data by following same steps. You need to create the directory Data under /media/ and also have to change the file /etc/fstab Reply.. –  Saurav Kumar Oct 29 '13 at 19:49

Since your /home is on pass 2 it may not be available as a mount-point when it tries to mount your DATA partition. Either specify pass 3 to the DATA partition or mount the DATA on /data and make a symlink from your home directory.

share|improve this answer
    
!! Does the 3rd pass even exist? BTW, symlinks will cause me many troubles because many configs on the sda5 require hard links :/ –  Ayman Oct 31 '13 at 12:06

From man fstab:

The mountall(8) program that mounts filesystem during boot also recognises additional options that the ordinary mount(8) tool does not. These are: ... and ``showthrough'' which permits a mountpoint to be mounted before its parent mountpoint (this latter should be used carefully, as it can cause boot hangs).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.