Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I need to install adobe air in my Ubuntu 13.10 x64. The installation shows this error,

dpkg: dependency problems prevent configuration of adobeair:
 adobeair depends on ia32-libs; however:
  Package ia32-libs is not installed.

Now I tried to install ia32-libs,

sudo dpkg --add-architecture i386 
sudo apt-get update 
sudo apt-get install ia32-libs

Now the error shows,

E: Package 'ia32-libs' has no installation candidate

And also tried,

sudo apt-get install ia32-libs:i386
sudo apt-get install ia32-libs-multiarch:i386
sudo apt-get install ia32-libs-multiarch
sudo apt-get install libc6:i386 libgcc1:i386 gcc-4.6-base:i386 libstdc++5:i386 libstdc++6:i386

Is there any working solution?

This solution also not working for me.

share|improve this question

marked as duplicate by Gilles, Alvar, karel, Avinash Raj, Eric Carvalho Dec 24 '13 at 0:06

This question was marked as an exact duplicate of an existing question.

No working solution here. – devo Oct 29 '13 at 17:35
Doesn't this answer work for you. Please edit your question with its results. – Aditya Oct 29 '13 at 17:40
No, this also not working. – devo Oct 29 '13 at 17:45
from where you downloaded adobe air? – Braiam Nov 8 '13 at 14:06
from I think it was from here – devo Nov 8 '13 at 16:42

You can use this:

sudo apt-get update
sudo apt-get install libgtk2.0-0:i386 libpangox-1.0-0:i386 libpangoxft-1.0-0:i386 libidn11:i386 gstreamer0.10-pulseaudio:i386 gstreamer0.10-plugins-base:i386 gstreamer0.10-plugins-good:i386 gstreamer0.10-ffmpeg:i386

share|improve this answer

Adobe Air is not supported in Linux (hence Ubuntu) anymore, that package was not prepared for being multi-arch ready, and that's why you get errors. I wasn't able to install Adobe Air in my 64-bit system by any sane means. You may be get lucky to find a version that still work, but that's under your own risk.

share|improve this answer
Now solved this issue using little hacky way. Installed adobe air and balsamiq mockup windows installer using wine. Now everything working. – devo Nov 16 '13 at 4:03

Not the answer you're looking for? Browse other questions tagged or ask your own question.